Results 1 to 9 of 9

Thread: abs and tc light

  
  1. #1
    Status
    Offline
    kevpott's Avatar
    AOC Regular
    Join Date
    Feb 2011
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    abs and tc light

    hi ppl i bought a astra coupe zlet which had the abs and tc light on with no speedo . i have replaced the hub on the passenger front and its still the same . i have had the ecu read and it comes back saying open circuit on that side . i have tested the wires up to the abs unit and there is no break in them as i am getting current through them . i have just put the tester on the both pins for the hub and i am getting current through the abs hub . is this right or is the new abs hub shot . any help would be greatfull kev

  2. #2
    Status
    Offline
    kevpott's Avatar
    AOC Regular
    Join Date
    Feb 2011
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    any got any ideas

  3. #3
    Status
    Offline
    AstraBoi2k8's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    715
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my light is on on mine and i am currently buying this part and going to see if it works will let you know
    Arden Blue GSI Turbo

  4. #4
    Status
    Offline
    [ELMO]'s Avatar
    Moderator Friend
    Join Date
    May 2008
    Location
    Didcot, Oxfordshire
    Posts
    7,316
    Mentioned in
    7 Post(s)
    Quoted
    1 Post(s)
    Have you checked the drivers side fella? May be worth checking the wires etc as I think you have replaced the wrong hub did you keep the passenger hub when you took it off?
    MK5 1.7 CDTI OWNER AND AN ESTABLISHED MEMBER OF THE DARK SIDE!

  5. #5
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    speed sensor is from the driverside fella

  6. #6
    Status
    Offline
    AstraBoi2k8's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    715
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my speedo is doing funy things its stayon on xero then jumping to about 30 when i get to that speed only sometimes though, so is this pass or driver side? probs worth while doing both at same time isnt it ?
    Arden Blue GSI Turbo

  7. #7
    Status
    Offline
    kevpott's Avatar
    AOC Regular
    Join Date
    Feb 2011
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah i kept the origanal hub from the passenger side . i thought it all worked from the passenger side. think i might have to put that one on to the drivers side and give it a try

  8. #8
    Status
    Offline
    [ELMO]'s Avatar
    Moderator Friend
    Join Date
    May 2008
    Location
    Didcot, Oxfordshire
    Posts
    7,316
    Mentioned in
    7 Post(s)
    Quoted
    1 Post(s)
    That's what I'd do fell, before you do though just pop the wheel off and check the wire from the hub to the plug, it might have frayed half way up which is salvageable without having to replace the hub
    MK5 1.7 CDTI OWNER AND AN ESTABLISHED MEMBER OF THE DARK SIDE!

  9. #9
    Status
    Offline
    j4ymo's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    158
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Steering wheel needs to be dead straight, I had this problem had to adjust 4mm taken from the right first, something to with steering angle sensor :/

Similar Threads

  1. Replies: 0
    Last Post: 23-10-2013, 20:06
  2. weird after fitting front mounted intercooler... fan light and engine warning light
    By Danithesqaudy in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 04-02-2011, 14:49
  3. 2004 zafira A - 1.8 A/T: Engine check light and Traction control light ON
    By cbcnestormn in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 06-04-2010, 15:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •