Results 1 to 4 of 4

Thread: ECU problem?

  
  1. #1
    Status
    Offline
    Kibedi's Avatar
    AOC Newbie
    Join Date
    Aug 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy ECU problem?

    Hi all,

    I recently got a new engine put in my astra mk4 1.8 SRi (52 plate) after this the car was in limp mode so I got the ecu checked out, camshaft/crankshaft sensors popped up, these got replaced but now the ecu has come up with even more readings!

    I've been told by vauxhall and another local garage that the ecu is dodgy and will need replacing, but others have said it might not be that which is causing the problem, now I'm stuck with what to do, I don't fancy forking out for a new ecu if my one is actually working correctly.

    The car still runs fine (so to speak) The problems I'm having are; car goes into limp mode when revved over 3000rpm in low gear, also when the car hits 85mph. Petrol consumption has increased vastly, and the oil temp guage hardly ever reaches the temp it should, at the moment it either sits at the zero point, occasionally reaching the quarter mark.

    Your help would be appreciated so I get a better idea of what the problem could be before I start blowing money for the sake of nothing : )

  2. #2
    Status
    Offline
    Chrisastmk4's Avatar
    AOC Newbie
    Join Date
    Nov 2010
    Posts
    16
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    well common fault is the temprature sensor, if that is faulty mate the car fuel mixture wont be correct and can cause limp problems, my cars been in and out of the garage last month and they said it was probs that, but i noticed for me anyways ive been resting my foot to hard on the clutch so its been running shit cos i keep riding the clutch

  3. #3
    Status
    Offline
    Kibedi's Avatar
    AOC Newbie
    Join Date
    Aug 2009
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'm getting the ecu checked out again over the next week, I'll get a full list of the faults. I'm not that mechanical minded but your theory seems to make sense, if the temp sensor is playing up, I'm assuming that would cause other faults to come out on the ecu readout?

  4. #4
    Status
    Offline
    Chrisastmk4's Avatar
    AOC Newbie
    Join Date
    Nov 2010
    Posts
    16
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    just changed the coil pack and has no completly made the car run like a dream matey give that a go as well

Similar Threads

  1. why does my remap cause a throttle problem and cruise control problem?
    By 22rabbits in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 21-08-2013, 14:50
  2. ECT problem or Idle Air Control valve problem?! =S
    By Jer7 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 22-12-2012, 13:50
  3. M1GST problem No. 145678,897,898.3 wierd door locking problem
    By MatG in forum Astra Discussion & Chat
    Replies: 22
    Last Post: 30-10-2008, 18:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •