Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: astra van 1.7td cutting out(HELP)

  
  1. #1
    Status
    Offline
    danhepworth's Avatar
    AOC Newbie
    Join Date
    Feb 2011
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    astra van 1.7td cutting out(HELP)

    hi there

    ive currently got an x reg astra van 1.7td, when the engine becomes warm the eml light comes on and the engine cuts off

    also ive noticed there is black oil in the header tank

    the van runs mint, no mayo under oil cap, pulls really well, heaters are warm, im just having this problem

    any help would be great

    thanks

  2. #2
    Status
    Offline
    andysterling's Avatar
    AOC Fanatic
    Join Date
    Sep 2010
    Posts
    538
    Mentioned in
    0 Post(s)
    Quoted
    3 Post(s)
    16v DTI? If so then it sounds like the crankshaft sensor is failing and the oil in the water is most likely a failed oil cooler, just bypass it, not needed.

  3. #3
    Status
    Offline
    danhepworth's Avatar
    AOC Newbie
    Join Date
    Feb 2011
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yes sorry its the dti, the van runs mint its just when the engine is warm

    i will do a search on the oil cooler

  4. #4
    Status
    Offline
    danhepworth's Avatar
    AOC Newbie
    Join Date
    Feb 2011
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Right guys a little update, I've changed the fuel pump ecu and crankshaft sensor, its still cutting out? Any more ideas? Goin to change the fuel filter tomorrow see if that makes a difference

  5. #5
    Status
    Offline
    astrasteve's Avatar
    AOC Obsessed
    Join Date
    Jan 2009
    Location
    East Yorkshire
    Posts
    3,347
    Mentioned in
    25 Post(s)
    Quoted
    20 Post(s)
    have you read any codes off
    my money is on the crankshaft sensor

  6. #6
    Status
    Offline
    jimdt's Avatar
    AOC Obsessed
    Join Date
    Oct 2007
    Posts
    5,338
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by astrasteve View Post
    have you read any codes off
    my money is on the crankshaft sensor
    he said hes already changed that?

    could be a air leak in the fuel somewhere any codes as above

  7. #7
    Status
    Offline
    danhepworth's Avatar
    AOC Newbie
    Join Date
    Feb 2011
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Not done a diagnostic check, we changed the fuel filter, seems there might be a blockage in the pipe leading to the tank, tried sucking and only getting small amounts of diesel through

  8. #8
    Status
    Offline
    astrasteve's Avatar
    AOC Obsessed
    Join Date
    Jan 2009
    Location
    East Yorkshire
    Posts
    3,347
    Mentioned in
    25 Post(s)
    Quoted
    20 Post(s)
    oh ye school boy error my mistake

  9. #9
    Status
    Offline
    paul.spencer's Avatar
    AOC Obsessed
    Join Date
    Feb 2008
    Location
    Waiwhetu, New Zealand
    Posts
    3,416
    Mentioned in
    0 Post(s)
    Quoted
    11 Post(s)
    Quote Originally Posted by danhepworth View Post
    Not done a diagnostic check, we changed the fuel filter, seems there might be a blockage in the pipe leading to the tank, tried sucking and only getting small amounts of diesel through
    Hey that's an interesting observation about possible fuel line blockage. I read a post recently about a load of crap that had to be removed from the fuel tank. Stuff that looked like leaves or similar. That's got to be worth investigating further.

    Also, somebody corrected me recently about the pedal test to get fault codes. I thought it didn't work for some diesels but I'm told that isnt true. So maybe try doing the pedal test and see if you can get any fault codes...

  10. #10
    Status
    Offline
    jimdt's Avatar
    AOC Obsessed
    Join Date
    Oct 2007
    Posts
    5,338
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by paul.spencer View Post
    Hey that's an interesting observation about possible fuel line blockage. I read a post recently about a load of crap that had to be removed from the fuel tank. Stuff that looked like leaves or similar. That's got to be worth investigating further.

    Also, somebody corrected me recently about the pedal test to get fault codes. I thought it didn't work for some diesels but I'm told that isnt true. So maybe try doing the pedal test and see if you can get any fault codes...
    that was me and there was loads of crap and sludge in the fuel sender thing goes a bit better now even if it wasnt the fault i was looking for

Page 1 of 2 12 LastLast

Similar Threads

  1. Astra G 1.8 Sri cutting out
    By BIG_G in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 23-10-2013, 06:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •