Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: few probs with x17dtl

  
  1. #1
    Status
    Offline
    Messsy's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    210
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    few probs with x17dtl

    i brought a W plate astra-g estate, 1.7 dti, when i drove it home the management light came on and it didnt pull, infact i had to pull over to the slow lane as i couldnt pick up speed. I thaught straight away it was the maf sensor but i pluged code reader in and got these codes.
    00163 - Engine coolant temperature, no signal, not present

    00002 - Engine coolant temperature, frequency out of range, not present

    00164 - Engine coolant temperature, incorrect signal, not present

    00017 - no engine RPM signal, present

    i think from these that the thermostat needs replacing as the needle for the temperature is stuck on 80 degrees all the way home, the air was hot when i put the fans on tho..

    Thats my first problem so any help would be great.

    Also need to know what oil to put in her, i have loads left over from a few petrol astras so if the x17dtl uses different oil then someone can have the bottles i have here (vauxhall stuff)

    The last thing, is there a service guide for this engine here? Its my first deisel so need to know im not missing anything.

    Thanks for any help or advice and ill get some pics up when my das6 has gone to work on her lol
    Current: Veccy-C 03 1.8i
    Previous Astra G's: W SXi 1.6i
    , 51 SXi 1.6i, 02 SRi 1.8i

  2. #2
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Im afraid there is no guide for this engine that im aware of.

    The fault with your temperature gauge would be your coolant temp sensor which would also cause it to run a bit rough as the engine wont know how hot it is.

    As for the 00017 code that will most likely be the crankshaft sensor and probably causing most of your issues.

  3. #3
    Status
    Offline
    Messsy's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    210
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers bud realy appreciated. Just brought thermostat but looks like im back at VX tomorrow lol.

    Any advice what to do to these engines to help them, dont mind spending a bit on her, thanks
    Current: Veccy-C 03 1.8i
    Previous Astra G's: W SXi 1.6i
    , 51 SXi 1.6i, 02 SRi 1.8i

  4. #4
    Status
    Offline
    17lowblow's Avatar
    AOC Regular
    Join Date
    Jan 2009
    Posts
    77
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    vauxhall lowblow engine?

  5. #5
    Status
    Offline
    Messsy's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    210
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    @jiberson, by coolant temp sensor do u mean thermostat inside the housing? Thanks

    @17lowblow, i dont know what that means, if you point me in the right direction ill tell you, thanks bud.. I did a bit of googling and cant find anything defining
    Current: Veccy-C 03 1.8i
    Previous Astra G's: W SXi 1.6i
    , 51 SXi 1.6i, 02 SRi 1.8i

  6. #6
    Status
    Offline
    Messsy's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    210
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok ive replaced the coolant temp sensor, crankshaft sensor and thermostat..
    Still have major problems with the car, when i drive eml comes on and it goes into limp mode, i have p400 error code which im sure this relates to gas's, my egr valve maybe? These are a part of the manifold
    Ill post the fault code details later when i get home but if anyone knows general things with these engines it could be please post up so i can look into sorting it..

    Thanks and ignor my above post im realy not that dumb just blonde haha
    Current: Veccy-C 03 1.8i
    Previous Astra G's: W SXi 1.6i
    , 51 SXi 1.6i, 02 SRi 1.8i

  7. #7
    Status
    Offline
    Messsy's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    210
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    oh sorry it is the lowblow engine by GM and from what ive heard im quite gutted. When it drives well it goes ok... When lol
    Current: Veccy-C 03 1.8i
    Previous Astra G's: W SXi 1.6i
    , 51 SXi 1.6i, 02 SRi 1.8i

  8. #8
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    At least youve cured you other error codes now, P0400 is a bit of a wild goose chase code but does generally indicate problems with the EGR valve. Probably best to take it off and clean it, not sure how easy it is to do on these engines.

  9. #9
    Status
    Offline
    paul.spencer's Avatar
    AOC Obsessed
    Join Date
    Feb 2008
    Location
    Waiwhetu, New Zealand
    Posts
    3,416
    Mentioned in
    0 Post(s)
    Quoted
    11 Post(s)
    Haha, I have to look up that UK reg system every time. I gather that W reg is something like year 2000.

    TIS 2000 indicates that would be the final year for the MK4 X17DTL and that the EGR valve is easily accessible, simple to remove and should be very easy to clean. Its not unlike the EGR valve on my older MK3 X17DTL and maybe just needs the crud cleaned off it.

    However with the MK4 X17DTL the problem may not be the EGR valve itself but may be the EGR solenoid valve that controls the valve, or possibly a leak in the vacuum system (tubes or elbows). Also, once in a while there's a post about finding oil in the vacuum tubing apparently from a leak in the vacuum pump at the end of the camshaft housing.

  10. #10
    Status
    Offline
    Messsy's Avatar
    AOC Regular
    Join Date
    Feb 2010
    Posts
    210
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    you are a life saver and i apreciate your time to post, i am jugling three kids on my own and have very little time to work on car so it is apreciated.
    I have located two bolts on the underside of the egr valve, i am not sure if i need a gasket once i replace the valve, ill be ringing vx to check price on solonoid today and i have cleaned the pipes through and checked them for leaks.
    The egr is gunked to hell as when i removed the pipes i could see it all, just wary about a gasket..

    Thanks and hope this will sort the car out, many thanks
    Current: Veccy-C 03 1.8i
    Previous Astra G's: W SXi 1.6i
    , 51 SXi 1.6i, 02 SRi 1.8i

Page 1 of 2 12 LastLast

Similar Threads

  1. op-com x17dtl
    By trc in forum Diesel Engines inc. Transmissions
    Replies: 3
    Last Post: 04-04-2012, 22:20
  2. 1.7 td x17dtl ecu
    By Rich JH in forum Diesel Engines inc. Transmissions
    Replies: 12
    Last Post: 24-11-2010, 17:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •