Results 1 to 7 of 7

Thread: dashboard swap, few things not working..

  
  1. #1
    Status
    Offline
    passion fingers's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    dashboard swap, few things not working..

    swapped my dashboard yesterday for a black one, thought it'd all gone smoothly.
    however few things are no longer working;
    >interior light
    >rear heated screen
    >electric windows
    >Odometer

    I've checked the relevant fuses (i think!) and they seem to be fine.

    anyone got any ideas?
    thanks

  2. #2
    Status
    Offline
    passion fingers's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Edit-
    also, my hazards work but my indicators don't?!

  3. #3
    Status
    Offline
    JT888's Avatar
    South Central RO
    Join Date
    Jul 2010
    Posts
    2,425
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when you say dashboard which bit do you mean? clocks? centre console? entire dash? could be a combination of fuses gone and/or something not plugged in properly or at all. either that or a dodgey connection that's been disturbed.

  4. #4
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Start with fuse 29 mate
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  5. #5
    Status
    Offline
    passion fingers's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by shadfall View Post
    when you say dashboard which bit do you mean? clocks? centre console? entire dash? could be a combination of fuses gone and/or something not plugged in properly or at all. either that or a dodgey connection that's been disturbed.
    the whole dashboard, kept the same clocks and centre console.

    indicators working agan, but all other faults reman, fuse 29 appears to be ok :/

  6. #6
    Status
    Offline
    passion fingers's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Every fuse is fine, cant find any loose connections either

  7. #7
    Status
    Offline
    passion fingers's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    going to take dash out again sunday, has anyone got any ideas on what to look for to solve the problems?

Similar Threads

  1. Dashboard Lights Not Working !!
    By LeeBarton1990 in forum Electrical
    Replies: 9
    Last Post: 27-08-2012, 18:14
  2. dashboard not working
    By willo 1988 in forum Electrical
    Replies: 3
    Last Post: 29-06-2011, 10:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •