Results 1 to 9 of 9

Thread: Water pump

  
  1. #1
    Status
    Offline
    MaseAmie SRI's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    475
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Water pump

    How long would you guys say a water pump would last for on the z20let?? Ive always thought when you change a cambelt you do the water pump. Only reason why i ask is ive been looking through the history invoices on my car and it had its first cambelt change at 39,508 miles in sep 2004 along with the water pump being changed. Then it had a second cambelt change at 90,235 miles in oct 2008 with no water pump. The current mileage now is 104,000 miles. Anybody have any thoughts on this??

  2. #2
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    If it were me I'd be considering a cambelt and waterpump change, not all garages suggest to do the pump so it is possible it's done 65k/7yrs on the same pump.

  3. #3
    Status
    Offline
    MaseAmie SRI's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    475
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    all the invoices i got are from a vauxhall garage so wouldn't they of suggested a pump change??

  4. #4
    Status
    Offline
    4EverSmitten's Avatar
    AOC Fanatic
    Join Date
    Mar 2010
    Posts
    381
    Mentioned in
    0 Post(s)
    Quoted
    3 Post(s)
    Vauxhall never suggested to change my water pump at 41k funnily enough but when I recently had the cam belt done at 80k it was squeeling a bit on start up so had to literally ask them to do it. Weird though why they dont force it on you. Must be their insurance policy that youll be back paying the same in labour to sort it out when it fails!
    CS3 - 262bhp 300Ib

  5. #5
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by MaseAmie SRI View Post
    all the invoices i got are from a vauxhall garage so wouldn't they of suggested a pump change??
    Doubt it, it isn't a standard item to change - they never told me my belt was due at 40k instead of 80k (I told them so they checked and 'Oh, yeah, so it is'), and never mentioned the waterpump either.

  6. #6
    Status
    Offline
    53gsi's Avatar
    AOC Fanatic
    Join Date
    Feb 2007
    Location
    Lincolnshire
    Posts
    416
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    When my gsi was 4years old i had the cambelt changed at vauxhall along with its service and they were'nt going to replace the water pump untill i asked them to and we also found the same thing with my dads astra at another vaux dealer,so i think its a case of if you dont ask you dont get.
    Arden Blue gsi Turbo 267bhp/282lbft
    +
    red sri turbo

  7. #7
    Status
    Offline
    MaseAmie SRI's Avatar
    AOC Fanatic
    Join Date
    Apr 2009
    Posts
    475
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    So i would be better off looking into changing it then. Is 65k/7 years a bit too much for a water pump or not??

  8. #8
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.9 cdti xpack
    Location
    Leeds
    Posts
    2,593
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    Quote Originally Posted by MaseAmie SRI View Post
    So i would be better off looking into changing it then. Is 65k/7 years a bit too much for a water pump or not??
    I was lucky with mine, only had a new one on for 40k and it started making a strange chirping noise when the engine was hot. I thought it was the alternator making the noise for weeks but then the pump failed and started pissing water out under the car. when I removed it there was lots of play in the bearing causing it to fail. I was lucky this time as the belt did nearly come off.

  9. #9
    Status
    Offline
    meanmatt's Avatar
    AOC Regular
    Join Date
    Feb 2011
    Posts
    237
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    think mine is on its way out. there is a like catching noise coming from my cambelt side on start up. and my water temp is getting very hot.
    mk4 astra gsi, arden blue, 2003

Similar Threads

  1. water pump and cam kit
    By stephen2006 in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 12-05-2006, 10:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •