Results 1 to 6 of 6

Thread: windshield wiper not working

  
  1. #1
    Status
    Offline
    hepzibah's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    windshield wiper not working

    hi- can anyone give me a rough idea what cost a windshield wiper motor and labour at garage please? my wipers dont work on slow, but on medium and fast they will run but then will stop in an upright position. this started on the way home today, and i stopped at a garage. they have booked it in for end of week, for an entire morning, as they don't know how long it will take to get to the motor, and then it would have to go back in next week to get a motor put in if that is what it needs. to me this seems like 2 lots of labour charges! ( the bloke thought it would be under £200- a fortune to me!)

    i have had a look and it seems that the arm that works the actual wipers is located just below a plastic grill ( grill between the windscreen and the bonnet) which has a foam clip thing running along the front edge, which seems to be all that holds that in place- this is apparant when i lifted the bonnet.

    as a old woman, it would make sense to me that the actual motor would be somewhere in the same vacinity?? my questions are; could this be done by someone other than a garage, and how long would it take to do it? and how much would i pay for a second hand motor? all advise much appreciated! thanks

  2. #2
    Status
    Offline
    DucatiEvo's Avatar
    AOC Regular
    Join Date
    Dec 2010
    Posts
    124
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    There are lots of threads on this so rather then reply and write the same stuff again, just stick 'wiper motor' in the search box from the menu bar, and you will have lots of information on the subject.

  3. #3
    Status
    Offline
    hepzibah's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thanks for your reply. i have looked at the other threads, and , with all due respect, they aren't really helping with the specific questions i have asked, so if anyone knows the answers to any of my querries, i would be very grateful. thanks

  4. #4
    Status
    Offline
    DucatiEvo's Avatar
    AOC Regular
    Join Date
    Dec 2010
    Posts
    124
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok well if it's a Mk4, then the motor is about £130 from Vauxhall and say 30mins to replace (assume hour labour charge minimum) and I would guess the £200 figure is about right. You can see the motor just above the brake servo (where the fluid goes in).

    It's actually a really easy job if you have the confidence and with a secondhand motor you could save yourself £££ for an afternoons worth of tinkering (if you haven't done it before)

  5. #5
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Very easy to do. I done mine for a tenner

    Went to the scrapyard and got a new motor for a tenner (they are usually a bit more, but this guy is generally only interested in stipping out the big bits.

    I went home, and all can be done with a good socket set.

    Remove both the wipers. (This can take some force if they have been on the car some time. Some WD40 whould help)

    Then remove the black plastic trim you mentioned, this will reveal the old motor. Follow the wires from it to the plug, and unplug it. Then unbolt the old motor, and bolt in the new one, and just reassemble as you took it apart.

    Simples.

    The non parking motor is a common fault.

    Also as mentioned above, if its:

    1998-2004 its a MK4 Astra
    2004-2010 its a MK5 Astra
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  6. #6
    Status
    Offline
    hepzibah's Avatar
    AOC Newbie
    Join Date
    Feb 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thank you both!!! just what i wanted- idiot ( me) proof advice!!!

Similar Threads

  1. Rear wiper not working...
    By hgerrard in forum Electrical
    Replies: 2
    Last Post: 16-02-2011, 15:30
  2. Rear wiper not working!!
    By J1400 in forum Bodywork and Exterior
    Replies: 3
    Last Post: 24-03-2004, 18:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •