Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Engine problems....

  
  1. #1
    Status
    Offline
    gsipower's Avatar
    AOC Newbie
    Join Date
    Jan 2011
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Engine problems....

    Hi all, newbie here with a sick Zaf GSi, got a service done 4 weeks ago, a week later starts juddering slightly and wanting to cut out, xmas eve on way home from work and it cuts out twice, ran a fault code check and came back with P0201, P0202, P0203 and P0204 - injector circuit malf, put new plugs in and a new coil pack, still the same, had a quick luk at connectors and all seem ok, air filter ok etc etc.
    Any ideas on this would be much appreciated.
    Thanks.

  2. #2
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    A long time ago I had these codes on my coupe, but they were random from piston to piston saying the injectors were at fault but the cause was a dead coilpack due to some nob putting the wrong type plugs in my car. as you have already changed them I would sugest getting the pulse tested on each injector with live data software. Only thing is its the dealers which could do this or maybe a friend you know has the software to test it for you.

  3. #3
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    If you havent already unplugged each injector plug and give it a clean with a bit of wd40, make sure the clips are not damaged on them just incase someone before has been messing about in there, failing that you'll have to get it tested properly mate. hope this helps a bit.

  4. #4
    Status
    Offline
    gsipower's Avatar
    AOC Newbie
    Join Date
    Jan 2011
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The fella who dun the service said he put NGK BKR5EK plugs in, wasnt sure what he took out, they r the same plugs i tried again, gona get sum new plugs from vauxhall 2moro and put a new fuel filter on, if its still the same after that then i'll try yr suggestion.
    Thanks.

  5. #5
    Status
    Offline
    gsipower's Avatar
    AOC Newbie
    Join Date
    Jan 2011
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    checked a couple of the breather pipes today, not good at all, full of gunk, took them off and give them a clean out and replaced them, put new vx plugs in and already seems to be running better, still dips in revs a bit but nowhere near as bad as b4, next step is a compression test and pulse test.

  6. #6
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.8vvt X Pack
    Location
    Leeds
    Posts
    2,594
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    BR5EK plugs made mine misfire before I changed to irridiums, if you want some good advice stay away from them plugs the guy fit for you. never had one bit of trouble using bkr6eix plugs plus you can leave them in longer only downside is the price

  7. #7
    Status
    Offline
    m5dkw82's Avatar
    AOC Obsessed
    Join Date
    May 2008
    Posts
    1,648
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Most z20let dont like std ngk (bkr5ek) and tune z20let definately dont like them

    bkr6eix are the ones to use (ngk irridiums) (ngk platinums also good)
    End of an era - She's gone to a good home

  8. #8
    Status
    Offline
    gsipower's Avatar
    AOC Newbie
    Join Date
    Jan 2011
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Thumbs Up

    Thanks for the info fella's, its much appreciated, this is my 1st Zaf Z20LET so i'm basically on a learning curve here, nice 1.

  9. #9
    Status
    Offline
    gsipower's Avatar
    AOC Newbie
    Join Date
    Jan 2011
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    happy days r here again...... car been running fine since put different plugs in and cleaned out the gunked up breather pipes, touch wood it stays like that, time to start saving the pennies and get some mods done.
    Thanks for the replies chaps.

  10. #10
    Status
    Offline
    gsipower's Avatar
    AOC Newbie
    Join Date
    Jan 2011
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Angry

    Spoke too soon didnt i, left work on thursday and car wouldnt start, tried a few things but ended up calling the rac, after being told it could possibly be the crank sensor i was towed home, got the new part and put it on, nothing, nowt, nil, zilch, now managed to spend about £230 and if anything its got worse.
    Still coming up with fault codes P0201, P0202 P0203 + P0204 (injector circuit fault).
    Can anyone give me some ideas please before i take a sledge hammer to the thing......
    Oh and another thing, as it is now its undriveable.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 03-08-2012, 01:44
  2. MK4 98 1.8 16v engine problems
    By FING3R5 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 5
    Last Post: 20-11-2011, 21:31
  3. Engine problems
    By bigman88jmf in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 27-10-2010, 15:18
  4. SXI Engine problems
    By tinhwp in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 02-04-2008, 14:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •