Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: astra gsi 0320!!!!!!!

  
  1. #1
    Status
    Offline
    kyle pugh's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    astra gsi 0320!!!!!!!

    anyone know this problem?

  2. #2
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    That code is crankshaft postion sensor fault
    The truth is always the truth even if you haven't realised it yet...

  3. #3
    Status
    Offline
    kyle pugh's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok cheers mate

  4. #4
    Status
    Offline
    kyle pugh's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    btw is that a bad thing? lol

  5. #5
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yes because that tells the ecu when to squirt the injectors etc or even if the engine is turning over if it fails completely.
    The truth is always the truth even if you haven't realised it yet...

  6. #6
    Status
    Offline
    kyle pugh's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ahh ryt i thaught the camshaft sensor number was 0340, what will happen if i continue to drive it?

  7. #7
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Its a generic fault code which means 'Ignition/Distributor Engine Speed Input Circuit'

    But as you dont have a dizzy its saying the fault is the crank sensor. Generic fault codes dont point to a specific faulty item.


    It may have been a 'glitch' and it not happen again or it may get worse. Worse case would be the car wouldnt start if it failed fully as the ecu wouldnt know the engine was turning.

    Get the code reset and see if it comes back.
    The truth is always the truth even if you haven't realised it yet...

  8. #8
    Status
    Offline
    webbo gsi's Avatar
    AOC Obsessed
    Join Date
    May 2007
    Posts
    1,548
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    get another put on mate! mine kept throwing this up and i left it! then the obvious happened! it failed completely and left me broken down. it controlls the fueling and ignition systems so if it cant register crank is turning then its never going to start.they are easy enough and cheap enough to just change! i think mine was about £30 from a local factors and its just a torx bolt to remove, its located down the front of the engine on the left hand side of the block nearest the belt end!
    At the end of the day, it gets dark!!!!!

  9. #9
    Status
    Offline
    kyle pugh's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok thanks for your help both will get that changed soon as

  10. #10
    Status
    Offline
    webbo gsi's Avatar
    AOC Obsessed
    Join Date
    May 2007
    Posts
    1,548
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by kyle pugh View Post
    ahh ryt i thaught the camshaft sensor number was 0340, what will happen if i continue to drive it?
    p0320 is crank!

    p0340 is cam

    dont get the two mixed up mate! they are totally different items!

    as already said, it might have just had a moment and corrected its self or it might be on its way out! when mine was going it would miss ever so slightly every now and then untill it died completely thats why i have advised to just get a new slapped on, at least then you know it wont go and break down on you!
    At the end of the day, it gets dark!!!!!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •