Results 1 to 2 of 2

Thread: Help! no power from engine.

  
  1. #1
    Status
    Offline
    Mantamalky's Avatar
    AOC Newbie
    Join Date
    Dec 2010
    Posts
    50
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Help! no power from engine.

    I have just had new valves fitted and replaced the cylinder head, the timing is correct and everything looks okay but there is no power from the engine, you can run the engine and drive the car but as soon as you get to a hill the engine just fades away, I think it might be the wiring or the fuel pipes are wrong, any suggestions would help.
    Cheers
    Malky

  2. #2
    Status
    Offline
    Mantamalky's Avatar
    AOC Newbie
    Join Date
    Dec 2010
    Posts
    50
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Help! no power from engine.

    Found and fixed the problem, the crankshaft pulley was worn at the location key and the pulley was moving, this was putting the timing out due to the crankshaft sensor, I could not get a replacement one so just positioned it correctly and drilled a hole through the pulley and into the crankshaft sprocket about 10mm, put in a tight fitting pin and bolted the pulley on, car now runs perfectly.
    Cheers
    Mantamalky.

Similar Threads

  1. Same engine, same power but god its different. My new toy
    By zaffy0 in forum Car Chat (other marques/models)
    Replies: 19
    Last Post: 20-02-2010, 20:38
  2. engine power
    By megi2007 in forum Astra Discussion & Chat
    Replies: 5
    Last Post: 08-02-2009, 15:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •