Results 1 to 6 of 6

Thread: EML problem ?

  
  1. #1
    Status
    Offline
    kenthepipe's Avatar
    AOC Regular
    Join Date
    Apr 2006
    Drives
    Astra G 1.6 SXI
    Posts
    178
    Mentioned in
    1 Post(s)
    Quoted
    8 Post(s)

    EML problem ?

    Sorry if this is in the wrong section, have looked at them all, if it,s wrong please move it.

    We have a 2002 1.6 SXi Astra, recently the engine management light came on, solid at first then a couple of miles it was flashing, then it stayed a solid light ever since.
    Took the car to have a diagnostic hook-up and it came up a fault on No2 whatever that may mean, they did mention two P numbers but sorry I don,t have them at the minute.
    They replaced the coil pack, and reset the computer, light now off, two days later the light came back on " solid" not flashing, Took it back and they reset it, saying things like "injector" or even worse "ECU".

    The odd thing is, that the car drives perfectly with no miss-fire or bad starting , you can,t fault it.., The garage said untill something radical shows up , there,s not much they can do, unfortunately that,s not really an option as the car is my daughters, she,s expecting soon and need,s the car to be reliable.., is it ok to drive with this light on, short term ?

    Any advice would be much appreciated

  2. #2
    Status
    Offline
    almo's Avatar
    AOC Newbie
    Join Date
    Jun 2010
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Had that problem as well some time ago......P0303.......and it was the Ignition Module that fits over the spark plugs ( it didnt give an engine miss either.....Module cost approximately £100 new- might be worth trying a scrappy.

  3. #3
    Status
    Offline
    GSi_Calum's Avatar
    AMDetails Employee
    Join Date
    Sep 2010
    Posts
    239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Could be AFM (air flow meter) i had the same problem with my old 1.8 sri
    Drives a Red Mk4 GSi

  4. #4
    Status
    Offline
    DeanF's Avatar
    AOC Fanatic
    Join Date
    Sep 2010
    Posts
    554
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Does sound like the Misfire Code in cylinder No2.

    The Misfire is detected the Eml illuminates & if the Misfire is still happening during detection The Eml Flashes.

    As stated, The cause of the misfire needs to be found !!!

    Dean

  5. #5
    Status
    Offline
    kenthepipe's Avatar
    AOC Regular
    Join Date
    Apr 2006
    Drives
    Astra G 1.6 SXI
    Posts
    178
    Mentioned in
    1 Post(s)
    Quoted
    8 Post(s)
    Quote Originally Posted by almo View Post
    Had that problem as well some time ago......P0303.......and it was the Ignition Module that fits over the spark plugs ( it didnt give an engine miss either.....Module cost approximately £100 new- might be worth trying a scrappy.
    forgive my ignorance, but is the ( Ignition Module that fits over the spark plugs) the same thing as the Coil Pack, as I believe that fits over the spark plugs also.., if so they put a new one on, no difference.

    Forgot to mention in the first post that they checked the condition of the spark plugs, non were oily and all the correct colour.., they also swapped them round.

    Thank,s

  6. #6
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    ignition module = coilpack, so you can rule that out.
    why on earth did they not renew plugs as well, if the coilpack fails then the plugs should be replaced at the same time.

    if it persists then i would get the injectors ultrasonically cleaned before condemning the ecu.

Similar Threads

  1. why does my remap cause a throttle problem and cruise control problem?
    By 22rabbits in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 21-08-2013, 14:50
  2. ECT problem or Idle Air Control valve problem?! =S
    By Jer7 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 22-12-2012, 13:50
  3. M1GST problem No. 145678,897,898.3 wierd door locking problem
    By MatG in forum Astra Discussion & Chat
    Replies: 22
    Last Post: 30-10-2008, 18:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •