Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: speedo and centre console lights not working

  
  1. #1
    Status
    Offline
    Bobber's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    126
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy speedo and centre console lights not working

    ive had a bit of a nightmare with my astra mk4 electrics recently, the lights in my clocks stopped working, so did the centre console lights, heater switch bulbs etc. also my rear fogs stopped working but ive managed to sort them now, it was the block not pushed in place onto the back of the light switch unit. as for trying to find the cause of the dash lights not working, i dont have a clue. now... ive tried another 2 sets of clocks, another couple of light switch units and checked all the fuses, checked the plug on the back of the heater control unit but just cant find anything. now, when i switch the lights on, the bulbs in the light switch unit light up (headlight adjustment and the sliding dimmer dial) but nothing else. the light dimmer wont work, the light switch unit stays on full brightness where as when all the lights are working even the light switch unit dims also. all the other lights work on the dash, indicators, oil light, fog indicator etc. i have tried checking the connector that goes into the back of the speedo dials with a multimeter to check every terminal with the lights on and off but i dont see any voltage change on any terminal so that to me indicates there is no live getting to the dash bulbs at all.
    sorry for the massive explination but i thought its best to let you know what ive tried so far,
    any info is much appreciated,
    Cheers,
    Rob.

  2. #2
    Status
    Offline
    N4J mk4's Avatar
    AOC Newbie
    Join Date
    Sep 2010
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    do u have a rev gauge ? does anything and ur dashboard work ?

  3. #3
    Status
    Offline
    Bobber's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    126
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah, all the dials work, all the indicator lights and stuff work, it just wont light up, all the bulbs are fine, so are the fuses, ive tried 3 sets of clocks and 3 sets of light switch units.. i just dont know what else it could be

  4. #4
    Status
    Offline
    N4J mk4's Avatar
    AOC Newbie
    Join Date
    Sep 2010
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    thts a weird one fair play and uve checked every fuse ? have u got a haynes manual book ? if not ill go take a look at myn and tell ya ?

  5. #5
    Status
    Offline
    N4J mk4's Avatar
    AOC Newbie
    Join Date
    Sep 2010
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ok is the connection alryt on it no burnt out wires or anything?

  6. #6
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Pin 3 on the headlight switch is the variable voltage output that goes direct to the multitimer before it goes onto the rest of the dash bulbs

    This is a Grey/Black wire
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  7. #7
    Status
    Offline
    Bobber's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    126
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers, ill give that a check tomorrow, if there is no power from that one, where shal I go from there?
    Cheers,
    Rob.

  8. #8
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    That comes direct from the headlight switch so can only be that
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  9. #9
    Status
    Offline
    Sooty's Avatar
    AOC Regular
    Join Date
    Jan 2011
    Posts
    83
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi guys im a newbie on here and just bought myself a 1.6 sxi and am having the same problem.

    I`d like to pre-warn you that i dont have much knowledge with electrics so please dumb things down if poss.

    What are the chances of this being the headlight switch unit?

    And in reference to pin 3 etc what am i looking for? (pics if poss would be a great help)


    Sorry to hi-jack someone elses thread.


    And thanks in advance!

    Sooty

  10. #10
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Sooty before you jump into this just check fuse 18 first as this is the usual cause of the dash not lighting up at night with the lights on
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Page 1 of 2 12 LastLast

Similar Threads

  1. Dash/centre console/window switch lights not working
    By jameshipkiss in forum Electrical
    Replies: 9
    Last Post: 01-09-2011, 12:55
  2. Centre Console Lights not working.
    By JB-Astra2.0-SRi in forum Astra Discussion & Chat
    Replies: 5
    Last Post: 22-02-2004, 18:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •