Results 1 to 4 of 4

Thread: 2007 Astra, heaters working but minimal heat

  
  1. #1
    Status
    Offline
    Astranewbie's Avatar
    AOC Newbie
    Join Date
    Dec 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    2007 Astra, heaters working but minimal heat

    Hi, I have a 2007 1.6 sxi. The heaters work on all settings (i.e 1-4) and the aircon works fine. However, the heaters don't get that hot. Yes they demist the windows and take the chill out the air but you could easily leave them on setting 2 or 3 for the whole journey and you still won't get too warm. Is this the thermostat? Also, no coolant leaks. Thanks.

  2. #2
    Status
    Offline
    scoop987's Avatar
    AOC Fanatic
    Join Date
    Aug 2010
    Posts
    601
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Header tank got enough coolant? If so, then it could be a blockage in the heater matrix. Maybe someone else will know better.

  3. #3
    Status
    Offline
    Astranewbie's Avatar
    AOC Newbie
    Join Date
    Dec 2010
    Posts
    5
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah the coolant levels are fine, checked them the other day.

  4. #4
    Status
    Offline
    ASTRA'GiLL'MK5's Avatar
    AOC Regular
    Join Date
    Jul 2010
    Posts
    138
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    maybe an airlock , when your sitting still do they go hot or do you need to be moving to get them warm ? Also Go to Your water bottle and check how hot that is ?

Similar Threads

  1. Heaters working when they want to MK4 Astra?
    By daz187 in forum Electrical
    Replies: 5
    Last Post: 13-11-2013, 16:34
  2. Heaters Not Working..
    By Jonesy in forum Electrical
    Replies: 14
    Last Post: 04-10-2008, 11:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •