Results 1 to 7 of 7

Thread: Urgent help needed

  
  1. #1
    Status
    Offline
    jonny22's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    858
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Urgent help needed

    Fitted my universal dump valve about an hour ago, took the car up and down the road with no problems at all, when coming back towards my house the car starts juddering and not boosting up properly and the spanner light comes on, next thing i know the engine is starting to cut out a little bit and the exhaust backfiring slightly.

    I get it back home and take the dump valve off etc and the spanner light is still on and the same symptoms. I had a full turbo back exhaust system put on friday and im waiting for a exhaust clamp to come through the post for the precat as its blowing.

    Could this be due to the exhaust not being set up properly?
    Any help will be appreciated as im quite a novice when it comes to turbo cars

    Thanks
    Jonny

  2. #2
    Status
    Offline
    jonny22's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    858
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Well been back to the exhaust place and he said the spanner light will come on until i get the exhaust clamp

  3. #3
    Status
    Offline
    JCSRI's Avatar
    AOC Premium Member
    Join Date
    Dec 2009
    Posts
    1,110
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Always annoying when a problem appears after something else is changed. Coincidence or what. hope its just the clamp for you fella.

  4. #4
    Status
    Offline
    AdamH-SRi-T's Avatar
    SRi Turbo :)
    Join Date
    May 2009
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    8,807
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    if the exhaust doesnt fit properly then it deffinatly wont help, but those symptoms lead too a boost leak so bad the car has reslised it...

    when a boost pipe pops off the car just judders and eventually stops. check all boost pipes and vac lines mate.

  5. #5
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by JCSRI View Post
    Always annoying when a problem appears after something else is changed. Coincidence or what. hope its just the clamp for you fella.
    Ad say that's why..I wudnt even drive it if it's blowing to be honest ..

  6. #6
    Status
    Offline
    JCSRI's Avatar
    AOC Premium Member
    Join Date
    Dec 2009
    Posts
    1,110
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Gsi Jase View Post
    Ad say that's why..I wudnt even drive it if it's blowing to be honest ..
    Niether would I m8 till I had got the clamp sorted..

  7. #7
    Status
    Offline
    jonny22's Avatar
    AOC Fanatic
    Join Date
    Apr 2008
    Posts
    858
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    im just gunna leave it until tuesdaylads

Similar Threads

  1. Urgent -- help or favour needed -- Urgent
    By MarkC in forum Scotland Region
    Replies: 6
    Last Post: 18-09-2006, 15:47
  2. Urgent Help needed
    By beastra in forum Astra Discussion & Chat
    Replies: 11
    Last Post: 30-12-2004, 15:11
  3. URGENT URGENT URGENT HELP NEEDED
    By kitchpoo in forum Astra Discussion & Chat
    Replies: 8
    Last Post: 30-08-2003, 13:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •