Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: a little blue smoke and using oil z20let

  
  1. #1
    Status
    Offline
    astra25's Avatar
    AOC Obsessed
    Join Date
    Jul 2010
    Location
    Chesterfield
    Posts
    1,788
    Mentioned in
    4 Post(s)
    Quoted
    15 Post(s)

    a little blue smoke and using oil z20let

    hi i have a mk4 astra gsi 91000 on clock when i start in in morining it sumtimes gives a little light blue smoke and also when i rev it it might give a little smoke out and i have to keep toping oil up every couple of tanks full i have a dump valve and that spits a small amount of oil out is this noumal could the oil problem be the turbo but in my opinion the car runs grate any help would be great many thanks.

  2. #2
    Status
    Offline
    Luke-Coupe's Avatar
    AOC Premium Member
    Join Date
    Nov 2008
    Posts
    2,673
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    How old is the turbo? Have you ever had the valve stems replaced?
    Coupe Turbo Evolution - 320ps

  3. #3
    Status
    Offline
    astra25's Avatar
    AOC Obsessed
    Join Date
    Jul 2010
    Location
    Chesterfield
    Posts
    1,788
    Mentioned in
    4 Post(s)
    Quoted
    15 Post(s)
    no i bought the car four month ago and done nothing engine wise but im guessing its still the original turbo.

  4. #4
    Status
    Offline
    Rainey88's Avatar
    AOC Fanatic
    Join Date
    Nov 2009
    Location
    Scarborough, North Yorks
    Posts
    890
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If its the original turbo id say its doing pretty well if its on 91000 :/ Check your intercooler pipes see how much oil is them if any that is..

  5. #5
    Status
    Offline
    Luke-Coupe's Avatar
    AOC Premium Member
    Join Date
    Nov 2008
    Posts
    2,673
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    If your still on original turbo at 91k that must be a record! In all seriousness though, the seals might be leaking on the turbo, the valve stem seals could be on their way out, Most valve stem seals i've known on Z20LET's start to give up around 70-80k

    Does it smoke under boost? Or does it smoke after it's been idling for a while and then you accelerate or if you let your foot off the accelerator going down and hill and accelerate at the bottom?
    Coupe Turbo Evolution - 320ps

  6. #6
    Status
    Offline
    astra25's Avatar
    AOC Obsessed
    Join Date
    Jul 2010
    Location
    Chesterfield
    Posts
    1,788
    Mentioned in
    4 Post(s)
    Quoted
    15 Post(s)
    im only talking about a small amound of smoke but id say just when i start it and when i put my foot down but i would,nt say it smokes every time i accelerate but like i say i have a dump valve and it spits a small amount of oil out.

  7. #7
    Status
    Offline
    astra25's Avatar
    AOC Obsessed
    Join Date
    Jul 2010
    Location
    Chesterfield
    Posts
    1,788
    Mentioned in
    4 Post(s)
    Quoted
    15 Post(s)
    it might be a good idea for me to take pre cat of and have a look if theres and movement in the shaft.

  8. #8
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if the dump valve is spitting oil then it points towards turbo

    Take the pipe off and have a look for oil
    GSi....boosting a' ower yer honda CTR, Vtec this!

  9. #9
    Status
    Offline
    Luke-Coupe's Avatar
    AOC Premium Member
    Join Date
    Nov 2008
    Posts
    2,673
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    Also check intercooler/boost pipes - How much oil would you say your using say every 1000 miles?
    Coupe Turbo Evolution - 320ps

  10. #10
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by astra25 View Post
    hi i have a mk4 astra gsi 91000 on clock when i start in in morining it sumtimes gives a little light blue smoke and also when i rev it it might give a little smoke out and i have to keep toping oil up every couple of tanks full i have a dump valve and that spits a small amount of oil out is this noumal could the oil problem be the turbo but in my opinion the car runs grate any help would be great many thanks.
    Just to add the car will run fine, but the seals will be leaking and oil seeping through getting burnt off.
    GSi....boosting a' ower yer honda CTR, Vtec this!

Page 1 of 2 12 LastLast

Similar Threads

  1. Z20let blue smoke help ?
    By biswell in forum Turbo Petrol Engines inc. Transmissions
    Replies: 5
    Last Post: 06-04-2014, 19:47
  2. Z20LET - Blue Smoke
    By MrZiggerz in forum Turbo Petrol Engines inc. Transmissions
    Replies: 4
    Last Post: 14-04-2013, 18:10
  3. Z20LET Blue smoke
    By Slickro in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 19-10-2007, 12:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •