Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Heaters switching between warm and cold

  
  1. #1
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Heaters switching between warm and cold

    Think i have an airlock in my heater matrix, so im frozen in the mornings.

    Car heats up in the morning as normal
    Blowers blow warm air until i stop at a junction. The air then becomes cold. As soon as i start driving again (Literally 20 meters) the air is warm again, up to full temperature. The cars engine temperature guage is at 90 degrees the whole time. Doesn't change.

    The car's water pump is only 10 months, and 6-7k old. I also have silicone radiator hoses, only fitted a few months ago, and coolant level is fine.

    Is there somewhere i should be able to bleed the airlock out from?
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  2. #2
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any Ideas?
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  3. #3
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any info welcome
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  4. #4
    Status
    Offline
    Toms1989's Avatar
    Soft Top VTEC :)
    Join Date
    Dec 2007
    Posts
    11,356
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    The systems I'm sure are self bleeding

    Failing that, run the engine on idle with the rad cap off an squeeze the hoses, it will work its way out eventually
    FULL Black Leather Heated coupe interior for sale! £200!!!
    Click Here

  5. #5
    Status
    Offline
    kirky's Avatar
    AOC Newbie
    Join Date
    Jun 2010
    Posts
    16
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You could try getting up to running temp with the expantion tank lid left off, worth a try but you might get a better solution as the night goes by, good luck will be watching.

  6. #6
    Status
    Offline
    bigchap's Avatar
    AOC Fanatic
    Join Date
    Feb 2010
    Posts
    310
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    there could be several problems here.
    1. head gasket
    2.thermostat
    3. radiator expansion bottle cap
    run your car at idle with the cap of expansion bottle and smell it.if you smell exhaust fumes your head gasket is away or check your dipstick,if it looks like the colour of a chocalate milk shake head gasket.if all seems ok there put cap back on and let it get up to temp and feel hoses,all should be very hot to the touch if any cold you have a blockage i.e radiator blocked or thermostat not opening correctlly.feel the two pipes at back of engine that go in and return from heater matrix.if all ok there changed the cap as there is a release spring in cap to let out pressure so doesnt get to hot if this is faulty it could be releasing pressure at wrong time.shouldnt be any air bloke as it would over heat.by the sounds of it a would change the cap as sound like its releasing pressure.good luck

  7. #7
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Head gasket it fine, i do an oil check often, thermostat is good, replaced less than a year ago, and engine temp stays at 90 the whole time, so the engine is running as should. Only the heaters are affected. All hoses are correct pressure and temperature to touch, im reasonably mechanically minded, but this one has me baffled.

    So the cap on the coolant reservoir may be at fault? Releases too much/too little pressure?
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  8. #8
    Status
    Offline
    Turboshed's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    2,333
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it could also be that the heater matrix has a blockage in it. When your driving, water is being forced in by the water pump at higher pressure, so it gets hot. When you stop, the pressure is not enough to keep the water flowing so the heater matrix cools down. You could try disconnecting the heater matrix pipes from the engine (both) and flushing it out with a hose pipe (reverse as to the normal flow from the engine) so that all the crap is flushed out the inlet pipe
    Probably the ONLY Astra Mk3 sitting on Corsa D SXI rims!
    And Now a Diesel on Discs all round!

    http://www.astraownersclub.com/vb/sh...d.php?t=162503

  9. #9
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Turboshed View Post
    it could also be that the heater matrix has a blockage in it. When your driving, water is being forced in by the water pump at higher pressure, so it gets hot. When you stop, the pressure is not enough to keep the water flowing so the heater matrix cools down. You could try disconnecting the heater matrix pipes from the engine (both) and flushing it out with a hose pipe (reverse as to the normal flow from the engine) so that all the crap is flushed out the inlet pipe
    Sounds like a good tip. Ill hopefully get some time in the morning to give that a try
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  10. #10
    Status
    Offline
    Turboshed's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    2,333
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    no worries mate
    Probably the ONLY Astra Mk3 sitting on Corsa D SXI rims!
    And Now a Diesel on Discs all round!

    http://www.astraownersclub.com/vb/sh...d.php?t=162503

Page 1 of 2 12 LastLast

Similar Threads

  1. zafria a heaters blowing warm not hot help ???
    By Stokieturbo in forum Zafira Discussion & Chat
    Replies: 9
    Last Post: 28-02-2014, 22:13
  2. Heaters stop blowing warm air when car is idling?
    By Smc92 in forum Astra Discussion & Chat
    Replies: 5
    Last Post: 26-01-2014, 21:31
  3. Cold heaters
    By cooper1973 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 18-01-2013, 00:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •