Results 1 to 3 of 3

Thread: emmision light prob.

  
  1. #1
    Status
    Offline
    axo's Avatar
    AOC Newbie
    Join Date
    Apr 2007
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    emmision light prob.

    Hi,
    I've searched the forum but cant find an answer to my cars problem.

    Astra 1.6 sxi 2002 pedal test brings up diagnostic code p0302 (Missfire Cylinder 2)

    Ive fitted a new Coil Pack and had a new set of Genuine GM Plugs fitted yet the emmision light stayed on. On odd occasions while driving power suddenly drains and the emmision light flashes if i go over 35mph?
    Any help would be great.

    Thanks Matt

  2. #2
    Status
    Offline
    Astramann's Avatar
    AOC Obsessed
    Join Date
    Nov 2010
    Posts
    1,197
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    had this problem before on a 1.8 sri i had, i would start the car and it would be fine but when i drove the light came on, it was down to burnt wires on the ecu and the car was being put into limp mode. and only 3 cylinders where firing.

    be best to check your ecu connections.

    or could be down to a faulty injector, connection etc.

  3. #3
    Status
    Offline
    axo's Avatar
    AOC Newbie
    Join Date
    Apr 2007
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi Thanks for the advice, i'll check the ecu connections today

Similar Threads

  1. 52 1.6 sxi flashing emmision light
    By 1.6sxi in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 25-01-2012, 22:27
  2. Engine emmision light
    By hreich in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 0
    Last Post: 25-05-2008, 12:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •