Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Heater controls! Only works on 4! Not 1,2,3!

  
  1. #1
    Status
    Offline
    db-astra's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    65
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Heater controls! Only works on 4! Not 1,2,3!

    My heater speed controls only work on the 4th setting!
    I have read that it's a resistor?
    Could anyone tell me how you replace this please?
    Any pictures will help too

    Thanks
    Dave

  2. #2
    Status
    Offline
    Brian's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    11,482
    Mentioned in
    142 Post(s)
    Quoted
    126 Post(s)
    Your better off replacing the whole control

    I have one if it helps

    Bri

  3. #3
    Status
    Offline
    SRI-T Keithy's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    5,745
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    Brian that wont cure the problem.

    It is the resister pack in the heater motor. It is a simple job on most cars but I am not sure where it is on a astra

    White is the new Black

    FARMYARD TUNING

    LEH IS THE FUTURE

  4. #4
    Status
    Offline
    Brian's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    11,482
    Mentioned in
    142 Post(s)
    Quoted
    126 Post(s)
    Quote Originally Posted by SRI-T Keithy View Post
    Brian that wont cure the problem.

    It is the resister pack in the heater motor. It is a simple job on most cars but I am not sure where it is on a astra

    Oh Me Bad

    Thanks

  5. #5
    Status
    Offline
    db-astra's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    65
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Brain, i thought that too, so i bought a new one off ebay for £11 :P
    Didn't make a difference so i looked into it abit more,
    Everyone say's it's the resistor on the resistor pack but how do you get to this??
    Does anybody know what size/rating the resistor is??

  6. #6
    Status
    Offline
    phil w's Avatar
    AOC Obsessed
    Join Date
    Sep 2007
    Posts
    2,089
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yes the resister pack is in the top of the heater box /motor , to gain access to this you need to remove the glove box , once the glove box is out you will see the heater ,the heater motor is the cylindrical part with the black and red wires coming out of it , follow these wires up the heater box they go to the resister pack , to remove the resister you have to push 2 black plastic lugs on the heater box apart to release the resister pack at the same time you have to pull the resister pack upwards ,that sounds more complicated than it really is ,
    I hope this makes sense lol

  7. #7
    Status
    Offline
    db-astra's Avatar
    AOC Newbie
    Join Date
    Feb 2009
    Posts
    65
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sorted ^_^
    Thanks very much Phil!

  8. #8
    Status
    Offline
    XxAstraxX's Avatar
    AOC Regular
    Join Date
    Aug 2010
    Posts
    190
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my heater doesn't work at all would this be the same problem ??
    its all wired in at the back
    Car : Black 2001 Astra 1.8 SRi Irmscher

    Z18xe Stage 1

  9. #9
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Could be the same problem but could also be a fuse or blower motor itself
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  10. #10
    Status
    Offline
    XxAstraxX's Avatar
    AOC Regular
    Join Date
    Aug 2010
    Posts
    190
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it decided to work for 10mins today was on number 4 only felt like number 1 does not work again, what would my first step be to finding the problem ?? thanks

    p.s sorry for hi-jacking your thread
    Car : Black 2001 Astra 1.8 SRi Irmscher

    Z18xe Stage 1

Page 1 of 2 12 LastLast

Similar Threads

  1. heater only works on no4
    By sxi andy in forum Electrical
    Replies: 4
    Last Post: 16-01-2007, 21:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •