Results 1 to 8 of 8

Thread: Problems :<

  
  1. #1
    Status
    Offline
    rm_14's Avatar
    AOC Newbie
    Join Date
    Sep 2010
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Problems :<

    my astra has been hit and miss this week.

    first problem was that it wouldnt go over 4200/4300 revs, it would just go into limp mode.
    it was also misfireing a bit while idle'ing. and generally felt like there wasnt much power in it

    so i changed the sparks, air filter/oil and oil filter, that diddnt fix it so i replaced the coil pack after seeing splits down the rubber seals...

    i thought that had fixed it!

    now it only seems to work fully when the engine is warm before its started :s
    i can tell if it will work depending on how it starts; if it only turns over once or twice, i have full power and all is fine.

    if it turns over more than that, iv still got problems


    its an 2001 SRi 1.8i btw
    also im pretty sure theres no e.m. bulb either. beause the pedal test doesnt work and surely something like this would make it come on..? :s


    any help would be much appreciated,
    thanks

  2. #2
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    need it on a tech 2 really see what codes u have, afm???

  3. #3
    Status
    Offline
    rm_14's Avatar
    AOC Newbie
    Join Date
    Sep 2010
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had thought about the afm - but have no way of testing it myself. not the cheapest of parts to replace either lol!
    hopefully on saterday i'll check weather there is a em bulb

    i tried on of those op-com interfaces off ebay...

    waste of time! coz it diddnt work - managed to get a refund tho.

  4. #4
    Status
    Offline
    Gsi Jase's Avatar
    AOC Obsessed
    Join Date
    Apr 2009
    Posts
    3,066
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by rm_14 View Post
    i had thought about the afm - but have no way of testing it myself. not the cheapest of parts to replace either lol!
    hopefully on saterday i'll check weather there is a em bulb

    i tried on of those op-com interfaces off ebay...

    waste of time! coz it diddnt work - managed to get a refund tho.

    See if Anyones local to u who wud lend u there's to test, also try ir local wreckers that's only thing I can think off mTe

  5. #5
    Status
    Offline
    DanMc_321's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    52
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the e.m light will come on with the ignition if it doesnt then u no thers no bulb in it !!
    Astra Convertible 1.6

  6. #6
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    Have you tried changing the coolent temp sender?
    ARDEN BLUE GSI

  7. #7
    Status
    Offline
    gissyturbo!'s Avatar
    AOC Obsessed
    Join Date
    Mar 2007
    Posts
    1,098
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Iv just taken my 2L apart your welcome to try my afm or coil pack if needed

  8. #8
    Status
    Offline
    rm_14's Avatar
    AOC Newbie
    Join Date
    Sep 2010
    Posts
    9
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sorted!!

    P0340 - Camshaft Position Sensor

    will be fitting a new one asap then all should be well!

Similar Threads

  1. 1.4 sxi idling problems and over fuelling problems
    By danny mcg in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 15-03-2014, 17:38
  2. Problems with car / Problems with Regal Autosport
    By BigG33 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 65
    Last Post: 10-07-2011, 13:00
  3. Replies: 59
    Last Post: 11-04-2007, 22:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •