Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 1.7 CDTi leaking diesel, injectors?

  
  1. #1
    Status
    Offline
    denny james's Avatar
    AstraSport Member
    Join Date
    May 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    1.7 CDTi leaking diesel, injectors?

    I have a 2003 Astra 1.7 CDTi diesel and a leak or leaks on the engine. It Diesel seeps up through the rubbers around what must be the injectors, the 2 end ones being worst, please see the pic. Is this a big issue or a fairly easy fix? I am pretty good with mechanics but really don't know that much about diesel engines so any help and/or tips appreciated.


  2. #2
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Is it diesel or oil?

    If its oil its those rubber gaskets, if its diesel its most likely the copper seal at the bottom of the injector.

  3. #3
    Status
    Offline
    denny james's Avatar
    AstraSport Member
    Join Date
    May 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by jiberson View Post
    Is it diesel or oil?

    If its oil its those rubber gaskets, if its diesel its most likely the copper seal at the bottom of the injector.
    I think it is diesel but now you ask I will have to double check. Diesel has a distinctive smell doesn't it? I am new to diesel engine cars.... you'd never guess!

  4. #4
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You normally would be able to smell diesel, it is quite potent yes im pretty new to them just got a good memory of previous threads i see around

  5. #5
    Status
    Offline
    denny james's Avatar
    AstraSport Member
    Join Date
    May 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I would say it's oil and from what I have found searching around it is the rubber seals that are the problem. I need to find where I can get them and what they are actually called.

  6. #6
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You can get em from vaux for a few quid, if you tell em your reg and what your after they can pull up a pic so you can point em out just to be sure.

  7. #7
    Status
    Offline
    denny james's Avatar
    AstraSport Member
    Join Date
    May 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by jiberson View Post
    You can get em from vaux for a few quid, if you tell em your reg and what your after they can pull up a pic so you can point em out just to be sure.
    Cool, I was going to phone them but probably worth the trip out to them to say "yes that's them".
    Cheers.

  8. #8
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If they dont show it you just ask em if you can check their EPC to see if theyre the correct part.

  9. #9
    Status
    Offline
    denny james's Avatar
    AstraSport Member
    Join Date
    May 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Good idea, not knowing exactly what they are called it's easier for me to look at them to confirm.

  10. #10
    Status
    Offline
    denny james's Avatar
    AstraSport Member
    Join Date
    May 2010
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    OK....... Got a problem now. I decided to take off the rubbers and reseal them. I disconnected the wiring plugs and the pipes and took off each rubber in turn and sealed them back in place with instant gasket and then reconnected everything. Now the car won't start! It is spinning over but not firing. Have I missed something here as I cannot see what has happened, everything is connected fine.

Page 1 of 2 12 LastLast

Similar Threads

  1. Astra g 1.7 cdti leaking injectors
    By Fear_1 in forum Diesel Engines inc. Transmissions
    Replies: 10
    Last Post: 23-08-2012, 09:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •