Results 1 to 6 of 6

Thread: t reg mk 4 astra diesiel cd please help

  
  1. #1
    Status
    Offline
    richiea's Avatar
    AOC Newbie
    Join Date
    Oct 2010
    Posts
    40
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Please help possible air mass flow eml on

    having dramas with mine my engine managment light keeps coming on but when i accelarate it goes off unless in 5th gear and go over 3000 revs then it stays on and car goes into limp mode untill i switch of and start up again. ever since the car hasl lost power and loses even more once limp mode is on. i took it to garage for diagnosic and they said it could be the egr valve and as mine is on the inlet manifold i need to replace the whole lot £400 they reckon . from looking on threads from these kind of forums it says signs are stalling and poor idling problems for which i dont car starts first time every time and never stalls so i thought it couldnt be that after a little think i took the air mass flow plug off and the engine management light came permantly on i then plugged it back in and light went off so i took it for a spin to my surprise my car has regained all its power and now the turbo is kicking in so all was good so i thought but once on motorway the same problem is happening soon as reach 3000 revs in 4th or 5th gear light comes on all that is different is i have regained my power so should i replace my air flow meter or egr valve. or is it that the ecu still has the fault logged and automatically puts the car in limp mode once i reached the certain revs i have tried resetting my ecu but dont think i was succesfull and not quite sure how to do it any suggestions please
    72247F7F-279C-BD18-FBA1-B2DB58F5BB62
    1.02.0572247F7F-279C-BD18-FBA1-B2DB58F5BB62
    1.02.05

  2. #2
    Status
    Offline
    richiea's Avatar
    AOC Newbie
    Join Date
    Oct 2010
    Posts
    40
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Please help possible air mass flow eml on

    Quote Originally Posted by richiea View Post
    having dramas with mine my engine managment light keeps coming on but when i accelarate it goes off unless in 5th gear and go over 3000 revs then it stays on and car goes into limp mode untill i switch of and start up again. Ever since the car hasl lost power and loses even more once limp mode is on. I took it to garage for diagnosic and they said it could be the egr valve and as mine is on the inlet manifold i need to replace the whole lot £400 they reckon . From looking on threads from these kind of forums it says signs are stalling and poor idling problems for which i dont car starts first time every time and never stalls so i thought it couldnt be that after a little think i took the air mass flow plug off and the engine management light came permantly on i then plugged it back in and light went off so i took it for a spin to my surprise my car has regained all its power and now the turbo is kicking in so all was good so i thought but once on motorway the same problem is happening soon as reach 3000 revs in 4th or 5th gear light comes on all that is different is i have regained my power so should i replace my air flow meter or egr valve. Or is it that the ecu still has the fault logged and automatically puts the car in limp mode once i reached the certain revs i have tried resetting my ecu but dont think i was succesfull and not quite sure how to do it any suggestions please
    72247f7f-279c-bd18-fba1-b2db58f5bb62
    1.02.0572247f7f-279c-bd18-fba1-b2db58f5bb62
    1.02.05
    72247f7f-279c-bd18-fba1-b2db58f5bb62
    1.02.05

  3. #3
    Status
    Offline
    Coo's Avatar
    Banned
    Join Date
    May 2003
    Posts
    25,105
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You can get code readers that will reset error codes....or go to a dealer.

    WTF is this:
    72247f7f-279c-bd18-fba1-b2db58f5bb62
    1.02.05


    Oh, and please space out your problems, very hard to read !

  4. #4
    Status
    Offline
    catman938g's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    1,483
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    they dont even look like "part numbers" do they!
    wouldnt read to much into what the garage said about your EGR valve, ive had garages read my codes and had EGR thrown up along with other codes, EGR been ok everytime. if your keeping the car buy a op com off ebay.
    you need to check all your vac pipes and rubber connections first, then check a second and third time cus its easy to miss where they have rubbed through sometimes. are the electrical connections at the pumps ok?
    how have you tried resetting the ECU?

  5. #5
    Status
    Offline
    richiea's Avatar
    AOC Newbie
    Join Date
    Oct 2010
    Posts
    40
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    thanks for replying

    hi thanks for getting bk to us them numbers just appeared when i edited my previous statment nothing to do with my car i will have a look for one of these op com and give it a try
    72247F7F-279C-BD18-FBA1-B2DB58F5BB62
    1.02.05

  6. #6
    Status
    Offline
    richiea's Avatar
    AOC Newbie
    Join Date
    Oct 2010
    Posts
    40
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    so by resetting the ecu you reckon the problem will go away or could it still be the air flow meter
    72247F7F-279C-BD18-FBA1-B2DB58F5BB62
    1.02.05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •