Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Coilovers stuck down. any ideas?

  
  1. #1
    Status
    Offline
    SteveC's Avatar
    AOC Obsessed
    Join Date
    Oct 2008
    Posts
    2,177
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Coilovers stuck down. any ideas?

    My raceland coilovers are stuck in their lowest setting and Im sick now. With the turbo lump in the car is stupidly low at the front and the exhaust sits just over an inch and a half off the floor and I cant afford to buy new flexi joints every month.

    The adjuster rings are stuck solid. Ive tried shock and unlock, a scaffy bar on the c spanner, blowtorch, oxyacetylene torch, more scaffy bar action on the c spanner and Ill ive succeded in doing is mashing the rings and bending the spanner.

    I have however had what I think may be a cunning plan. Im going to get some new adjuster rings, dismantle the coilovers and wind the springs down from the top which should probably work and get me some extra height. The problem Ive got is where do I get the new rings from? I cant find them anywhere
    It would definitely go better with an engine in it

    ZLET converted SXi See Here

  2. #2
    Status
    Offline
    ace275's Avatar
    AOC Premium Member
    Join Date
    Mar 2009
    Posts
    1,627
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have the exact same problem, though mine are jamex. ive tried all of the above even heating etc. Called jamex and they dont speak english.

    If you find out a place that sells new lockrings, let me know! Im considering replacing my coilovers
    Astra Sold! Now its back! Sold Again! Who knows whats going on!

    Currently Running MK1 1.8 MX5 with LSD awaiting boost, and a Red UK DC2

  3. #3
    Status
    Offline
    southwestastra's Avatar
    AOC Premium Member
    Join Date
    Aug 2009
    Location
    Weston-super-Mare, United Kingdom
    Posts
    2,651
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    how long have u had them fitted to ur car mate?

  4. #4
    Status
    Offline
    SteveC's Avatar
    AOC Obsessed
    Join Date
    Oct 2008
    Posts
    2,177
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by southwestastra View Post
    how long have u had them fitted to ur car mate?
    been on about a year and a half now
    It would definitely go better with an engine in it

    ZLET converted SXi See Here

  5. #5
    Status
    Offline
    [ELMO]'s Avatar
    Moderator Friend
    Join Date
    May 2008
    Location
    Didcot, Oxfordshire
    Posts
    7,316
    Mentioned in
    7 Post(s)
    Quoted
    1 Post(s)
    i posted up about the same thing yesterday, have tried everything i possibly could but to no avail
    MK5 1.7 CDTI OWNER AND AN ESTABLISHED MEMBER OF THE DARK SIDE!

  6. #6
    Status
    Offline
    [ELMO]'s Avatar
    Moderator Friend
    Join Date
    May 2008
    Location
    Didcot, Oxfordshire
    Posts
    7,316
    Mentioned in
    7 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by SteveC View Post
    I have however had what I think may be a cunning plan. Im going to get some new adjuster rings, dismantle the coilovers and wind the springs down from the top which should probably work and get me some extra height. The problem Ive got is where do I get the new rings from? I cant find them anywhere
    Just had a thought, do you have adjusters on the rear spring? If so would they fit on?
    MK5 1.7 CDTI OWNER AND AN ESTABLISHED MEMBER OF THE DARK SIDE!

  7. #7
    Status
    Offline
    DubCoup's Avatar
    AOC Fanatic
    Join Date
    Mar 2010
    Posts
    650
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    bang a load of wd40 on over a couple of days then let it settle in..mine have been on just under a year and will adjust by hand still

  8. #8
    Status
    Offline
    southwestastra's Avatar
    AOC Premium Member
    Join Date
    Aug 2009
    Location
    Weston-super-Mare, United Kingdom
    Posts
    2,651
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if its only a year n half id put loads of copper grease on the tread and contact raceland as u have a 2 year gar with it.
    and if theve gone they should send u out 2 new rings

  9. #9
    Status
    Offline
    SteveC's Avatar
    AOC Obsessed
    Join Date
    Oct 2008
    Posts
    2,177
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ive tried the all lube stuff and its been no good. When the turbo broke i had one off and steeped it in wd40 overnight and still no go. I spoke to a lad at spax who we deal with at work and he can sort me some new rings out but I need to find out the thread on them first. He also said that heating them makes the problem worse. With the rings being ally they expand at a different rate to the damper itself so its essentially welded them on. Ill try contacting raceland tomorrow too, I didnt realise the warranty was 2 years on them. At least I know for next time to properly grease the threads
    It would definitely go better with an engine in it

    ZLET converted SXi See Here

  10. #10
    Status
    Offline
    southwestastra's Avatar
    AOC Premium Member
    Join Date
    Aug 2009
    Location
    Weston-super-Mare, United Kingdom
    Posts
    2,651
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    true. its worth a try though.
    or u cld email raceland and ask tread size and see if they tell u.
    when i get mine on i plane to lube them at lest once a month

Page 1 of 2 12 LastLast

Similar Threads

  1. need some ideas stuck where to go next!!
    By mattpickin in forum Astra Discussion & Chat
    Replies: 20
    Last Post: 29-12-2012, 19:53
  2. My passenger door is stuck fast! any ideas??
    By tidy max in forum Bodywork and Exterior
    Replies: 6
    Last Post: 01-09-2010, 11:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •