Results 1 to 6 of 6

Thread: new turbo boost problems

  
  1. #1
    Status
    Offline
    B3N888's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    58
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    new turbo boost problems

    iv just fitted a vxr turbo under full boost all seems ok runs fine and seems smooth but under half throttle it is a bit jerky feels like the tc is coming on but it isnt. iv adjusted the actuator to about 4 threds. the only thing i can think could be causing this is that the crossover to engine breather hose is split. would this cause jerky boost? any ideas or thoughts?

  2. #2
    Status
    Offline
    MrStush's Avatar
    AOC Premium Member
    Join Date
    Jul 2008
    Posts
    2,625
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    When you say the breather is split, are you referring to the oil breather or another at the front of the engine??...
    Star Silver SRI Turbo..'Red.Dot Reloaded'..Cybox Precat, Cybox Catback SS Exhaust..K&N Panel Filtered...9Ltr EDS SMIC!!.....

  3. #3
    Status
    Offline
    B3N888's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    58
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by MrStush View Post
    When you say the breather is split, are you referring to the oil breather or another at the front of the engine??...
    No it's the pipe on the back of the engine that goes from the rockercover to the crossover pipe.

  4. #4
    Status
    Offline
    MrStush's Avatar
    AOC Premium Member
    Join Date
    Jul 2008
    Posts
    2,625
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    The one that's about 3" under the crossover pipe?.. This could be the issue so I would replace this anyway. However how far up the rev range and in what sort of gears do you find the jerky boost?.. Jerky boost could be due to a few possible issues.
    Star Silver SRI Turbo..'Red.Dot Reloaded'..Cybox Precat, Cybox Catback SS Exhaust..K&N Panel Filtered...9Ltr EDS SMIC!!.....

  5. #5
    Status
    Offline
    B3N888's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    58
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It is mostly in 2nd And a little in 3rd and is seems to start wen the boost comes in.
    And ye that's the pipe.

  6. #6
    Status
    Offline
    sam_888's Avatar
    AOC Obsessed
    Join Date
    Dec 2008
    Posts
    1,222
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Don't think it will be that pipe as that split on my 888 but didn't cause any problems. I replaced it any way but I can't see it causing a problem like that, its only a breather.
    Bit of a hard one though, I would check plugs, connections, air filter, make sure all boost pioes and vac pipes are tight, the basics really, it will probablly be some thing silly!

Similar Threads

  1. turbo boost problems
    By turboadz in forum Turbo Petrol Engines inc. Transmissions
    Replies: 13
    Last Post: 23-05-2013, 10:31
  2. astra g coupe turbo boost problems
    By booster in forum Turbo Petrol Engines inc. Transmissions
    Replies: 0
    Last Post: 21-05-2007, 13:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •