Results 1 to 3 of 3

Thread: astra coupe

  
  1. #1
    Status
    Offline
    m4rcus66's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    astra coupe

    z18xe engine /when starting my car from cold it starts ok but cant set off straight away its like its misfiring and wen rev car splutters thru tb any ideas guys i did put scanner on it which came up misfire cylinder 1 replaced coil pack but still same cant set off from cold got to wait few minutes then great

  2. #2
    Status
    Offline
    andy87's Avatar
    AOC Newbie
    Join Date
    Apr 2009
    Posts
    18
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    this is the exact same as mine i had it serviced, changed the coil pack, the airflow meter, cleaned the throttle body and still didnt fix it, just recently got the ecu sent away because that engine has the ecu on the engine block and it malfunctions due to the vibrations and the heat but still nothing, try a garage and ask about temperature sensor or the o2 sensor and if all else fails ask about the cat because it might be faulty

  3. #3
    Status
    Offline
    jimcoupe's Avatar
    AOC Fanatic
    Join Date
    Jul 2008
    Posts
    689
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    this sounds a bit like mine but i have a loads of power no codes and no warning lights so what could mine be but mines ok when cold untill the engine gets warm and then its starts to stutter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •