Results 1 to 5 of 5

Thread: astra 1.7 cdti sri cutting out.

  
  1. #1
    Status
    Offline
    gowers's Avatar
    AOC Newbie
    Join Date
    Nov 2008
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    astra 1.7 cdti sri cutting out.

    my astra 1.7 cdti sri was cutting out a couple of weeks ago and taking 20 mins to start again, looked on here alot was said about the crank shaft sensor needed doing, so took it to the garage they plugged it in and the crank shaft sensor come up, so they fixed it had it back a day and a half and it has cut out again and it now wont start. has anyone else had this fault or can any one else tell me wat it could be?? cheers

  2. #2
    Status
    Offline
    gowers's Avatar
    AOC Newbie
    Join Date
    Nov 2008
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    did i put this in the right place????

  3. #3
    Status
    Offline
    AndyH's Avatar
    Bit busy... be back soon!
    Join Date
    Jul 1971
    Drives
    Astra Coupe 2.2
    Posts
    300,024,286
    Mentioned in
    133 Post(s)
    Quoted
    30 Post(s)
    Follow AndyH On Twitter Add AndyH on Facebook Add AndyH on Google+
    Yes you did

    If no one has replied, it's possible no one else has had the same problem as you. Give it a while longer and see if you get any replies now the thread has been bumped.
    Actively proving that post counts mean jack sh*t since 1971

  4. #4
    Status
    Offline
    Banger Magnet's Avatar
    AOC Newbie
    Join Date
    Jan 2009
    Posts
    18
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by gowers View Post
    my astra 1.7 cdti sri was cutting out a couple of weeks ago and taking 20 mins to start again, looked on here alot was said about the crank shaft sensor needed doing, so took it to the garage they plugged it in and the crank shaft sensor come up, so they fixed it had it back a day and a half and it has cut out again and it now wont start. has anyone else had this fault or can any one else tell me wat it could be?? cheers
    I had the 'cutting out/starting after 20 mins' thing about 2 months ago. After scouring this and other sites the crank shaft sensor came up time after time.

    I had Greenflag and local garage plug my 1.7 cdti in but no sensor or any other faults came up.

    Anyway, went with web advice and back to local garage (also mate). Told him to replace crank sensor regardless - genuine vaux £70. He told me he similar problem a few years back which turned out to cam shaft senor so I had that done too. £140 for both with no labour charge. Run sweet as a nut straight after and no problems after two months.

    You said your garage 'fixed' the crank sensor - does that mean mended or replaced? How much did they charge? If it was replaced, was it gen vaux or other?

  5. #5
    Status
    Offline
    gowers's Avatar
    AOC Newbie
    Join Date
    Nov 2008
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it was over 100 pounds and they said it was a gen vaux part but the receipt is in the car and the car is still at the garage now they dont want to touch it cause they think it is the ecu
    cheers for the reply

Similar Threads

  1. Astra H 1.7 CDTI 100 – Z17DTH ---Cutting out---Help please
    By matthew01994 in forum Diesel Engines inc. Transmissions
    Replies: 12
    Last Post: 15-10-2015, 18:20
  2. Revs cutting out? Astra H 1.9 Sri cdti
    By Aaron.mass in forum Diesel Engines inc. Transmissions
    Replies: 6
    Last Post: 16-03-2014, 09:54
  3. Astra van 1.7 cdti Cutting out
    By Rob F in forum Diesel Engines inc. Transmissions
    Replies: 0
    Last Post: 13-06-2013, 13:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •