Results 1 to 9 of 9

Thread: Zafira ABS Question

  
  1. #1
    Status
    Offline
    MrT's Avatar
    AOC Newbie
    Join Date
    Dec 2003
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Zafira ABS Question

    Hi all,

    I have just got rid of my Mk4 Astra and brought a 2003 Zafira Club 1.6 (baby on the way)

    I think I have a wheel bearing that need replacing on the o/s front and need to know if I have ABS so I can order the right hub.

    When I turn on the ignition I dont see any ABS lights come on so was wondering if someone could post a picture and highlight the ABS pump that you can find in the engine bay. If you havent guessed already I am not particulary mechanically minded.

    Thanks in advance

  2. #2
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Passenger side needs ABS hub for speedo, drivers side doesn't need one, doubt there'd be ABS on the 1.6 but may be wrong - if the ABS light doesn't come on when you start the car then you won't have it.

  3. #3
    Status
    Offline
    MrT's Avatar
    AOC Newbie
    Join Date
    Dec 2003
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ahhh so you need an ABS hub for passenger side even if you dont have ABS?...

  4. #4
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    they are the same hun any way
    the car gets the speed from one of the front hubs on that year cant remember what side
    have a look at the rear of the hub for a wire on it

  5. #5
    Status
    Offline
    MrT's Avatar
    AOC Newbie
    Join Date
    Dec 2003
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers, I have jacked up the car on each side and "driven" it and the speed sensor is definately on the O/S so have ordered the relevant hub.

    Thanks for the advice

  6. #6
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    Easy one
    dose your car do this on start up


  7. #7
    Status
    Offline
    MrT's Avatar
    AOC Newbie
    Join Date
    Dec 2003
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It definately doesnt! So no ABS, but I still need the hub with ABS as its passenger side so I need it for the speed sensor.. I hope thats right anyway

  8. #8
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    the top one is a Vid of start up with ABS system putting Light on and off

  9. #9
    Status
    Offline
    MrT's Avatar
    AOC Newbie
    Join Date
    Dec 2003
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the help fellas... New hub sorted and running sweet!

    Just found 2 front discs and pads on ebay for £50 so gonna renew it all as my discs are slightly lipped.

Similar Threads

  1. Zafira question
    By AllanM in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 08-02-2004, 19:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •