Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: emissions light, please read this

  
  1. #1
    Status
    Offline
    stevothelegend's Avatar
    AOC Regular
    Join Date
    Dec 2009
    Posts
    196
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    emissions light, please read this

    i fitted a set of HIDs the other day and i removed my air box and unclipped which i assume is the airflow meter located on the air intake pipe post filter, just to give me some room, after fitting the HIDs i assembled the air box n stuff bk together but wen i started the van the nxt morning the emissions light was on and stays on, cnt remember if i tried the ignition on without the air feed meter attached wen i was checking 2 c if the HIDs wer working fine. if i disconnect the battery 4 a while should this remove the emissions light and if it says off then i no it was just a mistake on my behalf and theirs nothing actually wrong as ive tried the pedal tast and thers nothing showing in regards to codes. its a 1.7cdti astravan envoy 2006

  2. #2
    Status
    Offline
    Ben_M's Avatar
    AOC Obsessed
    Join Date
    Jul 2009
    Posts
    4,057
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mk5? did you get a canbus compatible hid kit?

  3. #3
    Status
    Offline
    stevothelegend's Avatar
    AOC Regular
    Join Date
    Dec 2009
    Posts
    196
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by b1988m View Post
    mk5? did you get a canbus compatible hid kit?
    mk 4, fitted h7r 8000k and they wrk fine just cnt remember if i tried 2 put ignition or if i even started the van without the airflow socket connected or if it was just a coincidence that the emissions light was on the following morning. van runs fine, but ive noticed wot can only be described as an electrical noise sound coming from around the diesel filter area at the back of the engine bay, u cn hear it if u click the ignition on and whilst engine running but disappears about 8<10 secs after switching the motor off, dont no how long this sound has been happening, hope sum1 can shed sum light on the situation.

  4. #4
    Status
    Offline
    stevothelegend's Avatar
    AOC Regular
    Join Date
    Dec 2009
    Posts
    196
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    any thoughts would be great.

  5. #5
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    Did you remove the airflow? Is it the correct way round with the arrow pointing in to the engine?
    ARDEN BLUE GSI

  6. #6
    Status
    Offline
    stevothelegend's Avatar
    AOC Regular
    Join Date
    Dec 2009
    Posts
    196
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Windrew View Post
    Did you remove the airflow? Is it the correct way round with the arrow pointing in to the engine?
    just unclipped the socket that was connected 8inches after the box then unclipped the top of the airbox and swung it out of the way, removed filter and pulled out bottom half of the airbox just so i had sum room to fit the modified bulb holder with the HID bulb in as it was proving a bit fiddly, i just want to no whether or not starting the engine without said socket connected wud make the instrument panel display the emissions light.
    i have no error codes and van runs fine thats wot makes me think ive dun sumthing in during the fitting of the HIDs to bring it on - or is it just a coincidence ?

  7. #7
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have u actually ran the car for a while to allow the ecu time to realise the AFM is actually connected and switch off the light itself?

    id be disconnecting the battery or ECU for half hour - check all connections and secure then once ur happy - drive it and see if it switches off

    personally though id whack it on the computer but dunno if u have access to one?

  8. #8
    Status
    Offline
    stevothelegend's Avatar
    AOC Regular
    Join Date
    Dec 2009
    Posts
    196
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    longest run ive dun is 5 mins just to work and then bk again, il disconnect the battery for half hour, wud i b rite in thinking the radio will ask for code after having been disconnected ? wer abouts are you from like geordie bandit ? and how much you charge for a diagnostics check, the bloke i normally use is a waste of space.

  9. #9
    Status
    Offline
    Hoops's Avatar
    AOC Obsessed
    Join Date
    Jul 2009
    Posts
    1,335
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Which light have you got on the dash? The one that looks like a tap or the spanner?



    or

    Astra Mk4 SRi Turbo Blog - Feel free to comment both good or bad.

  10. #10
    Status
    Offline
    stevothelegend's Avatar
    AOC Regular
    Join Date
    Dec 2009
    Posts
    196
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Hoops View Post
    Which light have you got on the dash? The one that looks like a tap or the spanner?



    or

    the 1st 1 the 1 that kinda looks like a tap

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 9
    Last Post: 25-03-2010, 19:18
  2. emissions light
    By Craig in forum Bodywork and Exterior
    Replies: 2
    Last Post: 11-07-2004, 13:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •