Results 1 to 8 of 8

Thread: Need some help!

  
  1. #1
    Status
    Offline
    Jakebros's Avatar
    AOC Newbie
    Join Date
    Jun 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Need some help!

    Well basically the last month ive had this squeeling noise coming from the passenger wheel area, which i assumed was a wheel bearing, but put a new hub on yesterday and it's still doing it just not as bad. But used the car this morning and it was just as bad, if not worse

    But i dont know what else it will be, any ideas?

    It only does it when im turning right or straightening up after turning left.

    Any help will be good

    Thanks

  2. #2
    Status
    Offline
    Brian's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    11,482
    Mentioned in
    142 Post(s)
    Quoted
    126 Post(s)
    I assume you have PAS power assited steering?
    Have you had any stiffness in the steering?

  3. #3
    Status
    Offline
    Jakebros's Avatar
    AOC Newbie
    Join Date
    Jun 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah i have. No, not that ive noticed.

    A mate said about the brakes rubbing but i cant see that it would be that cos it only does it steering right.

  4. #4
    Status
    Offline
    Brian's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    11,482
    Mentioned in
    142 Post(s)
    Quoted
    126 Post(s)
    Quote Originally Posted by Jakebros View Post
    Yeah i have. No, not that ive noticed.

    A mate said about the brakes rubbing but i cant see that it would be that cos it only does it steering right.
    Have you checked the power steering pump reservoir level?

  5. #5
    Status
    Offline
    jme_swaz's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could be the drive shaft? does it make a squeek when accelerating at launch?

  6. #6
    Status
    Offline
    Jakebros's Avatar
    AOC Newbie
    Join Date
    Jun 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Paula View Post
    Have you checked the power steering pump reservoir level?
    I havent, no. I will go check that and see

    Thanks

  7. #7
    Status
    Offline
    Jakebros's Avatar
    AOC Newbie
    Join Date
    Jun 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by jme_swaz View Post
    could be the drive shaft? does it make a squeek when accelerating at launch?
    Im not sure tbh, ive just got used to it and only really hear it when i turn, but im going out later so will have a listen

    How much will it be too fix if it is the driveshaft, do you know?

  8. #8
    Status
    Offline
    jme_swaz's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    not to sure, depends whether you can do it yourself or not. can pick driveshafts up for around 30pounds if you should around.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •