Results 1 to 7 of 7

Thread: coupe turbo and not sure if it performing right????

  
  1. #1
    Status
    Offline
    Richard Santos's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question coupe turbo and not sure if it performing right????

    Hi. Canny new to this sight and have a problem. I have just bought a gold coupe turbo. Its had 1 previous owner from new totally imac and totally standard!!!!
    Not sure if the turbo is going coz it drives fine but im not sure if it should be faster???? It is a bit smoky when i punch it 2. Slight whisle from low revs when its cold but still goes alright.

    Does this mean i will need the turbo replacing?????

    Hope someone could help.

    Cheers Rich

  2. #2
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds suspect, could be the turbo

  3. #3
    Status
    Offline
    fordy191's Avatar
    AOC Regular
    Join Date
    Oct 2009
    Posts
    97
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    What sort of millage has the car done?
    Astra G - Z16XE

  4. #4
    Status
    Offline
    Rudeboy_khan's Avatar
    AOC Fanatic
    Join Date
    Jul 2009
    Posts
    319
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    turbo or air flow meter... do you have dash light on... if not turbo...others shall confirm... btw welcome to AOC pix due plzz

  5. #5
    Status
    Offline
    Richard Santos's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi. Thanks for the welcom. Will put pics on soon. Millage on car is 87000 on a 2001. There are no warning lights on at all and like i said the car still goes ok but its not much faster than my old vectra sri 150. Dont want to splash out on a new turbo if this is not the problem???? Thanks for all the replys

  6. #6
    Status
    Offline
    roswell's Avatar
    AOC Fanatic
    Join Date
    May 2004
    Posts
    433
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when was it last serviced, whats the condition of the oil ?

  7. #7
    Status
    Offline
    Richard Santos's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Last serviced feb 2010 with full oil change. I had the roker cover changed when i got the car as it had slight oil leek but 2 days ago i had to put more oil in as i think there is a very slight leek from the sump???? Would the turbo be burning oil if it was faulty?? I have been in contact with the previous owner who owened the car bought from vx in 2001 with 900 miles on and he serviced with oil change every 6000 miles and timing belt every 40k. If the turbo was going would it just go?? or would it just die out after a period of time.

Similar Threads

  1. mk4 not performing help
    By jacques nel in forum Turbo Petrol Engines inc. Transmissions
    Replies: 1
    Last Post: 29-09-2010, 22:11
  2. coupe turbo not sure if its performing right????
    By Richard Santos in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 07-08-2010, 12:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •