Results 1 to 4 of 4

Thread: 2.0dti loss off power when towing

  
  1. #1
    Status
    Offline
    father635's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    2.0dti loss off power when towing

    I could do with some help to find this problem please
    I use my van to tow our caravan as I find my vectra 1.8 not man enough.
    What happens after a few miles is I struggle to get more than 40 mph but I found out on the last trip if I turn off the ignition it will be ok again for a while. It doesnt seem to follow any pattern I just came back from Yorkshire 125 miles with no problem but on the way there it did it 3 times . It also struggles to run at low revs yet will tick over ok
    Any help would be greatly received
    Many thanks

  2. #2
    Status
    Offline
    Spedo's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    848
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It might help to get the fault codes read which may point you in the right direction, if you are getting no codes I would look for poss air ingress into the fuel system, also make sure your plug to the fuel pump is really tight it should not wiggle from side to side, if it does unplug it clean it and gently pinch the contacts together to make better connection. It may also be a faulty crank sensor which won't always show up on the fault codes.

  3. #3
    Status
    Offline
    father635's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Many thanks

  4. #4
    Status
    Offline
    catman938g's Avatar
    AOC Obsessed
    Join Date
    Jan 2010
    Posts
    1,483
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    crank sensors always fail when your engine warms up when they are knackered, its a good theory and code reading will throw that up.

Similar Threads

  1. Help? Smoke, Oil Loss, Rattle, Power Loss, Normal??? Perhaps Not..
    By RickAstra21 in forum Astra Discussion & Chat
    Replies: 4
    Last Post: 28-03-2009, 17:32
  2. 2.0DTi Juddering and Loss of Power
    By dave_coupe in forum Diesel Engines inc. Transmissions
    Replies: 8
    Last Post: 09-08-2007, 14:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •