Results 1 to 9 of 9

Thread: Help! Astra G 1.6 8v estate issues

  
  1. #1
    Status
    Offline
    teknosquidgy's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question Help! Astra G 1.6 8v estate issues

    Hi there all, newby so hope I am in the right place

    My astra mk4 (1.6 8v estate) is having a few problems and I have heard getting an updated ECU is the solution. Apparantly the ones with mf stamped on is the old fault prone one and Vaux bought out an updated one? My symptoms are lack of power, erratic high idle (sometimes) and feels like a miss in the motor? I have replaced the EGR valve thinking that was my issue...the engine is a x16szr with 138k on the clock

    Can anybody give me some insight here?

    Thanks all!

  2. #2
    Status
    Offline
    Turboshed's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    2,333
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    does the engine management light come on at all to give you any idea or problems. Though the high idle could be down to the Idle control valve needing cleaning, not sure on lack of power or the engine missing
    Probably the ONLY Astra Mk3 sitting on Corsa D SXI rims!
    And Now a Diesel on Discs all round!

    http://www.astraownersclub.com/vb/sh...d.php?t=162503

  3. #3
    Status
    Offline
    teknosquidgy's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi there Turboshed...light came on before replacing EGR valve couple of months back but not since. she is running very sluggishly with a definite miss...idling is not smooth, no power either.

  4. #4
    Status
    Offline
    Turboshed's Avatar
    AOC Obsessed
    Join Date
    Aug 2008
    Posts
    2,333
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You could do the paperclip test to see if the ECU throws any stored fault codes up, that might point you in the right direction. But the missfire might be caused by the cam sensor or even crank sensor, both of these are common faults, along with the idle control valve. It might also be worth cleaning out the throttle body as these tend to get all gummed up after time and become sticky
    Probably the ONLY Astra Mk3 sitting on Corsa D SXI rims!
    And Now a Diesel on Discs all round!

    http://www.astraownersclub.com/vb/sh...d.php?t=162503

  5. #5
    Status
    Offline
    greenmini's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,291
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    hey there, my astra g had these problems before and it was a combination of things so ill list them just to help you out here:
    firstly check your not suffering a misfire, check plugs, leads, coilpack then failing that camshaft sensor.
    secondly egr. which u say you have replaced. iv got a blanking gasket between mine and the ecu has been updated to reflect this.
    Delete all the fault codes using opcom or tech2
    Lastly iv had my ecu updated by my mate who works for vx, u dont have to change it basically there is a software update that can be applied via tech2. good luck!
    1.6 8 valve, 5 door, soon to be a 5 studded let with crusty arches

  6. #6
    Status
    Offline
    teknosquidgy's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks GreenMini...I think I will start by replacing coilpack, ht leads and plugs (was gonna do that anyway) Where do I find the crank and cam sensors situated...can u point me in the right direction? Thanks!

  7. #7
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    What brand of EGR did you fit?

  8. #8
    Status
    Offline
    teknosquidgy's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hiya nry, it was a vaux one as far as I can remember...It did not sort out my issue so i kept the egr plugged in but blanked off the hole? i have since put it all back as was as my issues did not really go away...

  9. #9
    Status
    Offline
    teknosquidgy's Avatar
    AOC Newbie
    Join Date
    Jul 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Could anyone tell me where to find the idle control valve on the x16szr please? want to give it a good clean! thanks everybody for their input so far in this thread...much appreciated!

Similar Threads

  1. little issues that need resolving mk5 estate
    By shikari_ferrari in forum Interior
    Replies: 6
    Last Post: 08-10-2010, 08:53
  2. Mk3 Astra estate alternator dashboard issues
    By rucil in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 22-12-2009, 00:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •