Results 1 to 6 of 6

Thread: ECU Fixed but still more fault codes!!

  
  1. #1
    Status
    Offline
    Jay_R's Avatar
    AOC Fanatic
    Join Date
    Jul 2008
    Posts
    496
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    ECU Fixed but still more fault codes!!

    After having issues pointing towards my ECU i had it tested and repaired, put it all on and its running sweet but after driving 50 miles i though id do a quick pedal test when i got home to see if its all nice and clear....NO!! i now have other codes but it doesn't seem to be affecting the car.

    now have: (do i need to have it Tech 2'ed again to determine what code it is?)

    0530-

    P0530 A/C Pressure Sensor Circuit Low Input Heating, Ventilation and Air Conditioning System C-009
    P0530 A/C Pressure Sensor Circuit High Input Heating, Ventilation and Air Conditioning System C-009
    P0530 A/C Pressure Sensor Malfunction Heating, Ventilation and Air Conditioning System C-009

    1481-

    P1481 Fan Control 1 Circuit High Voltage Engine Cooling B-004
    P1481 Fan Control 1 Circuit Low Voltage Engine Cooling B-004
    P1481 Fan Control 1 Circuit Open Engine Cooling C-003
    P1481 Fan Control 1 Powerstage High Temperature Engine Cooling C-003

    1482-

    P1482 Fan Control 2 Circuit High Voltage Engine Cooling B-004
    P1482 Fan Control 2 Circuit Low Voltage Engine Cooling B-004
    P1482 Fan Control 2 Circuit Open Engine Cooling C-003
    P1482 Fan Control 2 Powerstage High Temperature Engine Cooling C-003

    1483-

    P1483 Fan Control 3 Circuit High Voltage Engine Cooling B-004
    P1483 Fan Control 3 Circuit Low Voltage Engine Cooling B-004
    P1483 Fan Control 3 Circuit Open Engine Cooling C-003
    P1483 Fan Control 3 Powerstage High Temperature Engine Cooling C-003

    I have checked that the fan comes on when the temp hits 90degrees at idle and it does but i understand there are 3 different settings for the fan...can someone explain this to me so i can check this..

    also the air con works(although not very cold as it needs a refill)

    Engine temp on dial is fine also.

    After a bit of searching this could be a relay??? or fuse...iv checked the fuses and none are blown so do need to check the relays..how much are these and how do i know what one i need.

    other thing is , it could be another fault with the ECU possibly??? ideas??

    also while i was waiting for the ecu i sent my injectors off for cleaning so i unplugged all the relevant bits...could this have affected it?? but i only put the negative battery clip on after it was all connected back up so i doubt this?

    by the way anyone thinking of having there injectors cleaned...do it...definatly worth the £50....so much smoother and nicer all around.

    anyway anyone got any ideas on the above fault codes?? i thought if a relay was duff it would make a noise?? and it seems that i have 3 relays at fault?? but like i say the car is running fine with no management lights on at all.

    astra is starting to get a wee bit expensive now lol

    any ideas what i could try ect or if anyone has seen this before??/

    Thanks people

    Jay

  2. #2
    Status
    Offline
    zafiraowner's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    345
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Those errors all looks related to the ECM module (Engine Cooling module)..

    Maybe that module is on the fritz also... ?

    Regarding the fan stages.

    There are different stages that will be engaged if certain criteria is met. If the car gets to XX degrees, stage 1 will be active. If the temperature rises even more then stage 2 will be active and so forth.

    Stages = Speed of the fans.

    No need to run the fan at flank speed just to lower temperature a few degrees if the lowest speed can manage.

    Zafiraowner

  3. #3
    Status
    Offline
    Jay_R's Avatar
    AOC Fanatic
    Join Date
    Jul 2008
    Posts
    496
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    after a bit more searching i only have one fan so i think its the dual fan thing rather than two(as its got air con) i think this doesn't have a control module either(although i aint looked yet) so any ideas....knew that it wouldn't just go smoothly...its my luck lol

  4. #4
    Status
    Offline
    zafiraowner's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    345
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If the car has one fan AND it has aircon then this might be the problem

    Dont know about Z16XE astra's but my Z18XE zafira (2002) has 2 fans and i would have thought that yours has 2 also.

    Also if it has aircon then it should have the cooling module..

    Easy way to know if it has the cooling module is to get in the car and turn the key to ignition without starting...If there is a lit symbol of a box with a cog wheel inside then it has the module.

    The module is located in the left side behind the front bumper.

    This module is prone to failure because it sits so close to the road and sometimes water gets into the connector and corrodes the pins ...

    Zafiraowner

  5. #5
    Status
    Offline
    DanMc_321's Avatar
    AOC Newbie
    Join Date
    May 2009
    Posts
    52
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my car was throwing up the code 1482 after having an accident ! :-/ took it bk to the garage it was fixed at and they said it was a sensor so they replaced that but it dint change they then sent my car to vauxhall and they have sed it needs a new ECU £552 + VAT + Fitting ! :-O just waititng to see if insurance says yes it can be fixed if not im ****ed dont no what i will du !!!!! hope this helps mate ! but then again if u have just had ur ecu fixed i dont understand it ?? maybe its not been fixed properly !!
    Astra Convertible 1.6

  6. #6
    Status
    Offline
    zafiraowner's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    345
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If insurance says no ask them how much they are willing to pay you to get it fixed yourself and source a second hand Cooling ECU from a scrappy...

    Zafiraowner

Similar Threads

  1. maf sensor fault fixed-worth a read!
    By Devil within in forum Turbo Petrol Engines inc. Transmissions
    Replies: 8
    Last Post: 02-05-2013, 20:16
  2. ECU Fixed but still more fault codes!!
    By Jay_R in forum Electrical
    Replies: 0
    Last Post: 25-07-2010, 15:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •