Results 1 to 10 of 10

Thread: Mid and bass not working!!

  
  1. #1
    Status
    Offline
    philly's Avatar
    AOC Premium Member
    Join Date
    Oct 2007
    Posts
    77
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Mid and bass not working!!

    I am have a few issues at the moment with my set up. I have a Sony XM-GTX6020 powering a set of Infinity REF6022I
    front 2 way components. Problem is that all I seem to be getting out of the is the treble from the tweeter and nothing fron the mid. Could this be down to a pinched wire or do you think the components are Kapput?? The Infinitys are a few years and the Amp is brand new as the last Amp gave up one me last week. Could this have damaged the speakers??

    HELP!!!!
    Mines a pint!!

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Has this been the case ever since you got your new amp? Maybe it needs the filters setting up
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    Bubba's Avatar
    AOC Obsessed
    Join Date
    Feb 2007
    Posts
    3,729
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    As above, check the high pass and low pass filters, you will need to set these up on the amps.

  4. #4
    Status
    Offline
    philly's Avatar
    AOC Premium Member
    Join Date
    Oct 2007
    Posts
    77
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It only has a LPF and that was switched off. I've had a look at the crossover and taken it apart. Somehow the wiring around the coils which is normally insulated has overheated and shorted out the crossover. I've bought some new speakers now same as these-

    http://www.caraudiocentre.co.uk/prod...si_p-25174.htm

    If anybody has an idea on how to repair crossovers I would appreciate it as the speakers thenselves I'm hoping will still be ok?
    Mines a pint!!

  5. #5
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Where were the crossovers mounted?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  6. #6
    Status
    Offline
    philly's Avatar
    AOC Premium Member
    Join Date
    Oct 2007
    Posts
    77
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    They weren't just in the door bagged up and cable tied so they didn't get wet.
    Mines a pint!!

  7. #7
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    But were they inside the door or between the plactic membrain and door card?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  8. #8
    Status
    Offline
    philly's Avatar
    AOC Premium Member
    Join Date
    Oct 2007
    Posts
    77
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Inside the door mate. They are just simple in line crossovers so just bagged up. The amp had just recently gone as well so I think that may have damaged the speakers somehow.
    Mines a pint!!

  9. #9
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Well IMO crossovers shouldn't go in that part of the door, even when bagged up. You get a fair amount of water in there and if it managed to get in the bag that can act as a trap that holds the water to do even more damage.

    If they were just inline ones that go to between the wiring and mid/ tweeter it sounds like there's not alot you could have done about mounting them elsewhere though
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  10. #10
    Status
    Offline
    philly's Avatar
    AOC Premium Member
    Join Date
    Oct 2007
    Posts
    77
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I know what you mean. I'm thinking I will try and mount in the door card this time. Got the new speakers due tomorrow so happy days. Cheers geezer.
    Mines a pint!!

Similar Threads

  1. Replies: 1
    Last Post: 06-05-2012, 12:59
  2. Need more BASS!!
    By jonuk7 in forum ICE Mk4|G
    Replies: 15
    Last Post: 02-12-2007, 17:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •