Results 1 to 10 of 10

Thread: interference help

  
  1. #1
    Status
    Offline
    bobby84's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    124
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    interference help

    ive changed all my speakers for pioneer items and would like to amp them up. The only problem is when ever i amp them i get engine interference throgh them . Ive also got a sub that is wired up to a capacitor and the amp on that has a low pass filter on it and when this is on all is good but swithch it off i get the same interference. Ive tried every trick i know icluding moveing the earth point and it is realy starting to do my nut any suggestions greatly appreciated
    you gotta love it when you make the boys weep

  2. #2
    Status
    Offline
    andyt_2005's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    198
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have you got the power cable running seperate to the rca's? like different side of the car?

  3. #3
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Pioneer headunit aswell by any chance?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  4. #4
    Status
    Offline
    bobby84's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    124
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ive got the power carriers down the left and the RCA's and speaker wire down the right.

    And yes, Pioneer head unit.

    I never had this problem with the corsa even though the power and RCA's ran down the left together. Ive tried an inline surpressor on the RCA and that hasnt worked one bit.
    you gotta love it when you make the boys weep

  5. #5
    Status
    Offline
    vxlaney's Avatar
    AOC Regular
    Join Date
    Jun 2008
    Posts
    134
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    bad earth? or rca terminals on the headunit or the amp faulty?

    unplug the rca leads from the amp (with headunit off) then start the car and turn on the engine, if it still buzzes then i would say the amp has bad earth.

  6. #6
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Seems to be a bit of a problem with Pioner headunits, I have the same

    I believe you can confirm it's a headunit fault by earthing the outter part of the RCA connector at the headunit
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  7. #7
    Status
    Offline
    icetony's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    44
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You need one of these mate. Cheap and will solve your problem instantly.

    http://www.maplin.co.uk/Module.aspx?ModuleNo=33172
    I <3 Speakers so i do

  8. #8
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Quote Originally Posted by icetony View Post
    You need one of these mate. Cheap and will solve your problem instantly.

    http://www.maplin.co.uk/Module.aspx?ModuleNo=33172
    I tried one of them and it didn't fix my problem
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  9. #9
    Status
    Offline
    chrisgs23's Avatar
    AOC Fanatic
    Join Date
    May 2010
    Posts
    329
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could it be a faulty rca?
    try 2 rcas with a splitter on and see if you still get the noise!

    i had this problem with my old car was annoying, high pitch noise when you rev the car, and an alternator supressor didnt work, rca supressor didnt work, ground lop isolater didnt work, but may for you, autoleads do a good ground loop isolator
    chrisgs23
    aka astravanchris
    astra mk4 van

  10. #10
    Status
    Offline
    bobby84's Avatar
    AOC Regular
    Join Date
    Jun 2010
    Posts
    124
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yea, high pitch noise when revving, isolator didnt work. Gonna have a fiddle with it at some point, just got the brake calliper to sort yet
    you gotta love it when you make the boys weep

Similar Threads

  1. ice interference
    By nugg_GTE in forum ICE Mk1|2|3
    Replies: 0
    Last Post: 27-07-2011, 03:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •