Results 1 to 3 of 3

Thread: Battery problem?

  
  1. #1
    Status
    Offline
    ben_sri's Avatar
    AOC Regular
    Join Date
    Jan 2010
    Posts
    280
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Battery problem?

    Driving home the other day, everything was going well, until getting near to my house when the battery light switched on. Strange. I then had to steer when I realised another problem - no power steering. I understand the power steering is controlled by an electric pump, so obviously the problem is related.

    A friend checked the battery with a multimeter, which seemed to be running fine at 12v, which made him think the alternator isnt at fault.

    What do you guys think, faulty battery? or something possibly worse?

    Cheers

  2. #2
    Status
    Offline
    richardw's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    78
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi,
    If you are only getting a voltage reading of 12 volts, then the alternator is faulty - it should be 13 - 14 volts if the alternator is charging.

  3. #3
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    As above, most likely the alternator.

Similar Threads

  1. Battery Problem!
    By andyb313 in forum Electrical
    Replies: 5
    Last Post: 22-09-2008, 21:57
  2. Battery Problem???
    By Mark_W in forum Electrical
    Replies: 12
    Last Post: 09-11-2007, 00:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •