Results 1 to 4 of 4

Thread: Running Hot!

  
  1. #1
    Status
    Offline
    XpLoD's Avatar
    AOC Premium Member
    Join Date
    Oct 2008
    Posts
    386
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Running Hot!

    Hey guys,

    Sorry for bothering again .
    After i fitted my FMIC i noticed that my car is running very hot, this happens especially @ highet Rpm's and on higher speeds.
    Last time i was in Germany going round 200km/h and noticed that my coolant temp went up to 97 degreec celcius.

    My temps are usually round 90 degrees while driving normal, but when u pushing it it goes high.

    I also fitted a cool running thermostat today, but did not see any diffrence.

    Anyone had these familiar issues?
    Thanks.
    Once U Go Fast U Never Go BACK!

  2. #2
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    have a look at fitting a uprated Alloy Rad to the car keeps them temps down a lot
    my car stays around 87 to 90

  3. #3
    Status
    Offline
    buckle's Avatar
    /
    Join Date
    Sep 2004
    Posts
    18,921
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by XpLoD View Post
    Anyone had these familiar issues?
    Thanks.
    Mine has been the same since fitting FMIC. It restricts airflow to the rad so to be expected I guess.

    Your intake temps should be lower than before though which is the main thing.

  4. #4
    Status
    Offline
    XpLoD's Avatar
    AOC Premium Member
    Join Date
    Oct 2008
    Posts
    386
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by buckle View Post
    Mine has been the same since fitting FMIC. It restricts airflow to the rad so to be expected I guess.

    Your intake temps should be lower than before though which is the main thing.
    Yea it really is. it dropped with round 15-20 Degrees.

    I was worried about these high temp, but if the Thermostat opens full @ 97 and it stays there then i dont think theres not much to worry about.

    Thanks for help guys.
    Once U Go Fast U Never Go BACK!

Similar Threads

  1. What boost should I be running?\possible running problem
    By CraigJG in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 11-10-2010, 18:01
  2. Car running sluggish due to running out of petrol????
    By voodoo_jellybaby in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 25
    Last Post: 21-12-2005, 20:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •