Results 1 to 3 of 3

Thread: Engine Management Light coming on after cleaning throttle body?

  
  1. #1
    Status
    Offline
    trancem's Avatar
    AOC Regular
    Join Date
    Nov 2009
    Posts
    202
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Engine Management Light coming on after cleaning throttle body?

    Hey guys, I was having loads of ICV problems... Stalling on idle, revs fluctuating up and down etc.. So I took it to my mate who's got a garage.. and he took out the throttle body and cleaned it with petrol.. We left it to dry for a few hours and fit everything back together... The stalling seems to have stopped so I think that's sorted.. But the engine management light is now on.. Is there any reason for this?

    He's asked me to bring it back on monday to get rid of the light but i'm wondering why the light is on in the first place? Is there any way to check? Is it the pedal test or something?

    Also, after going for a quick blast, there is a slight cut in power at about 2000rpm.. why is this after we've just cleaned the throttle body?

    any ideas?

    The car in question is a 1999 Astra 2.0 SRi (dont know what engine code that is?)

    cheers guys

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its the X20XEV u have and the pedal test is no good, however the paperclip test should work - essentially its a case of briding pins 5 & 6 on the OBD port and counting the sequence of flashes of the EML on the dash

    details here:

    better still, why not ask in ur regional forum, see if anyone has opcom or similar and they can run a full diagnostics on their laptop to see all the data - may even be better than ur "mate" at the garage - especially if they wanna fleece u at the same time!

    whenever i clean any TBs or similar, i always disconnect the ECU so any lights are removed etc

    u can try this, or disconnect the battery for half hour, or turn the ignition on then off 20 times (wait for self check lights - eg airbag etc) to go off first each time....

    but ideally read the code first if u can get the paperclip test to work, THEN clear it how i mentioned above.

    HTH

  3. #3
    Status
    Offline
    trancem's Avatar
    AOC Regular
    Join Date
    Nov 2009
    Posts
    202
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'll have a search around for the paperclip test and give this a go tomorrow mate and let you know how I get on..

    Your link didnt work by the way?

    Thanks for the help

Similar Threads

  1. Cleaning throttle body.. Normal engine oil OK?
    By trancem in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 29-05-2010, 16:34
  2. Cleaned Throttle Body..Engine Management Light appearing intermittently
    By ClubTec in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 04-11-2008, 17:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •