Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Z18XE respons issues

  
  1. #1
    Status
    Offline
    Revox's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z18XE respons issues

    My girlfriends car has some issues when I change gears. Especially from 1. to 2. and somwhat to 3.

    When i've changed the gear and release the clutch to put on power there isn't any. It take's a second or two and it reacts. It's like it dies for a second and comes back.

    It doesn't misfire or anything like that. Also if I have it in neutral and pump the gaspedal it reacts very slowly from when it's released and i push it down again. I can have it flored for a second or two before the revs start climbing again.

    It wasn't like this before and compared to my car it's daft as a dead horse.

    What can be wrong?

    Edit : This issue also makes it hard to start from 0. I really have to build up revs and keep the power on to get the car rolling or it will choke. Hillstarts are a bit easier cause I can just keep alot of power on and start. But at flat roads it's either wheel spin or nearly choking the engine.

  2. #2
    Status
    Offline
    zafiraowner's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    345
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If the revs sorta drop to 500 and not want to go higher it sounds like my car with same engine.

    Mine only did it from cold though but in the end i changed the MAF sensor and it now runs like it should.

    Zafiraowner

  3. #3
    Status
    Offline
    Revox's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    My problem can occur at any revs.

    I've had a suspicion it could be related to the MAF sensor or the airfilter. It also feels like it's somewhat down on power.

  4. #4
    Status
    Offline
    micky taylor 888's Avatar
    AOC Regular
    Join Date
    Jul 2008
    Posts
    245
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could be any of the following, maf, dirty throttle body, sticking egr valve, there is a wireing mod for the airflow meter vaux sell a kit and if you ask the dealer nicely they should print you off the relevant field remedy for it

  5. #5
    Status
    Offline
    dark_cobra's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Location
    edinburgh
    Posts
    330
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Does anyone have any more info on this wiring mod mentioned above?

  6. #6
    Status
    Offline
    Fraggle's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,038
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by dark_cobra View Post
    Does anyone have any more info on this wiring mod mentioned above?
    http://www.astraownersclub.com/vb/sh...d.php?t=254138

  7. #7
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    wiring mod is for x18 not z18

  8. #8
    Status
    Offline
    Revox's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the feedback. If the wiring mod is for x18 it's useless. I just have to go over the filter, MAF,EGR etc and check if there's any faults with them.

  9. #9
    Status
    Offline
    Broomies Mate's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by steve1412 View Post
    wiring mod is for x18 not z18
    Did they fix this issue with the later engines?

    My brothers Z18XE reacted extremely well with the mod...... even clearing the MAF codes!

  10. #10
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    yes it was improved with better wiring and updated version software ecu

Page 1 of 2 12 LastLast

Similar Threads

  1. issues when starting z18xe
    By airthy in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 12
    Last Post: 26-01-2011, 19:04
  2. >>> Z18XE issues <<<
    By Darren SXi 1.8 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 33
    Last Post: 27-04-2007, 15:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •