Results 1 to 7 of 7

Thread: warning lights z20let

  
  1. #1
    Status
    Offline
    zhabba's Avatar
    AOC Premium Member
    Join Date
    May 2010
    Posts
    350
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)

    warning lights z20let

    Hi Everyone this is my 1st post........

    Can anyone tell me what these two codes mean? drove to wales 160 miles over the weekend car was fine did not do anything silly at all on the motorway, today i started up and I have the light with a radiator and fan on it and also the car with the spanner please help, also seemed to have blown fuse 39 replaced but blown again and light came back

    thanks in advance

  2. #2
    Status
    Offline
    swins89's Avatar
    AOC Newbie
    Join Date
    Aug 2009
    Posts
    14
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    poss be electric water pump, one that sits ifront of g.box. only a guess

  3. #3
    Status
    Offline
    iansimms2004's Avatar
    AOC Obsessed
    Join Date
    Mar 2009
    Posts
    3,814
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    What engine is it? Is the car showing any symptoms? poor running etc etc? The more information you give regarding what you know the better the answers you will get.

    And search pedal test on the search option on here and do it. It should give you fault codes which you can then search for on net and here and may get some answers.
    For free hugs PM me.

    For sex, pm cabriomatt.

  4. #4
    Status
    Offline
    zhabba's Avatar
    AOC Premium Member
    Join Date
    May 2010
    Posts
    350
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    hi there sorry bout that its a astra coupe turbo z20let 04 plate, no i dont have any running problems, done the pedal test and i think i am getting p0530 but some say its ac problems and some say it aux coolant pump, any idea where this is located and what it looks like, also as fuse 39 keeps blowing my coolant fans and AC dont work, if i locate this aux coolant pump and dissconnect it i would like to think it would answer my questions and diagnose the issue, but is it safe to do this, also if i was to drive with these warning lights on/aux pump disconnected what damage could occur thanks

  5. #5
    Status
    Offline
    ashsri-t's Avatar
    AOC Fanatic
    Join Date
    May 2010
    Posts
    347
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    you could try your igntion on listen if your pump is pumping under battery tray or may feel it pumping (slightly vibrating) or if you cant hear or feel the coolant pump mite be seized?

  6. #6
    Status
    Offline
    zhabba's Avatar
    AOC Premium Member
    Join Date
    May 2010
    Posts
    350
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    i will try but will it start to work from 1st start up or do i have to warm the vehicle first as i though this pump only works when the vehicle is hot and switched off

  7. #7
    Status
    Offline
    ashsri-t's Avatar
    AOC Fanatic
    Join Date
    May 2010
    Posts
    347
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    if im write i think it pumps as soon as you turn ignition on hot or cold as on my old turbo i had a noisy pump and could hear it as soon as ignition was turned on.i will check for you 2mo and see if mine comes on on cold start up and let you no if thats any help to you?

Similar Threads

  1. Warning lights
    By wolfiessam in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 07-04-2010, 19:37
  2. warning lights
    By routley in forum Electrical
    Replies: 0
    Last Post: 12-10-2008, 10:54
  3. Warning lights
    By Manne in forum Electrical
    Replies: 1
    Last Post: 05-08-2007, 20:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •