Results 1 to 3 of 3

Thread: Astra H Accelerator Pedal Sensor errors

  
  1. #1
    Status
    Offline
    sib123's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra H Accelerator Pedal Sensor errors

    Hi,

    on my Astra H 2005 - Z18XE i've been getting these fault codes via my tech2 - and every other day my car is going into limp mode... I clear the codes and after a while it comes back... been reading alot of posts about this - have pulled apart the accelerator sensor and pedal and cant see anything loose or obviously wrong with it... have cleaned the throttle housing and im out of ideas - has anyone got any good advice?


    Number of stored fault codes: 3
    P1120 - Accelerator Pedal Position Sensor 1 and 2 Signal Incorrect Ratio
    (52) - Not present
    P1550 - Electronic Throttle Control Reduced Power
    (01) - Not present
    P1122 - Accelerator Pedal Position Sensor 2 High Input
    (01) - Not present

    also getting these codes about the steering wheel;


    Number of stored fault codes: 3
    P0815 - Steering Wheel Remote Control Shift Up Switch Circuit Resistance Range/Performance
    (0 - Present
    P0816 - Steering Wheel Remote Control Shift Down Switch Circuit Resistance Range/Performance
    (0 - Present
    U2120 - CAN-Bus No Communication with AHL (Headlamp Levelling Device)
    (00) - Present

  2. #2
    Status
    Offline
    zafiraowner's Avatar
    AOC Fanatic
    Join Date
    May 2008
    Posts
    345
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You can use livedata to see if the voltages of acc pedal circuit 1 and 2 are bad. If it works like mine the 2 voltages added should read about 5 volts at all times. I guess that they made it this way to prevent a single "potentiometer" failing it would do the Toyota turbo acceleration trick

    Zafiraowner

  3. #3
    Status
    Offline
    sib123's Avatar
    AOC Newbie
    Join Date
    Jan 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi - thanks for your reply... i've run live data and detailed below... what do you think?

    Battery Voltage
    11.9 V
    Fuel Pump Relay
    Inactive
    APP at Idle Position (Accelerator Pedal Position)
    Inactive
    APP Sensor 1 (Accelerator Pedal Position)
    0.96 V
    APP Sensor 2 (Accelerator Pedal Position)
    0.47 V
    Calculated Pedal Position
    0.00%
    TP Sensor 1 (Throttle Position)
    0.78 V
    TP Sensor 2 (Throttle Position)
    4.22 V
    Calculated Throttle Position
    7%
    Throttle Position PWM Servo Signal
    0%
    Throttle Position
    Idle
    TP Sensor 1 Learned Lower Position (Throttle Position)
    0.35
    TP Sensor 2 Learned Lower Position (Throttle Position)
    2.04

Similar Threads

  1. ***** accelerator pedal sensor *****
    By Animal_Winnie in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 0
    Last Post: 03-11-2010, 08:18
  2. Astra H Accelerator Pedal Position Sensor
    By sib123 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 8
    Last Post: 13-05-2010, 22:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •