Results 1 to 7 of 7

Thread: car chuggers when at cruising speed

  
  1. #1
    Status
    Offline
    9obamartins's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question car chuggers when at cruising speed

    ive bought an s reg astra 1600 16 valve club and since i bought it ive noticed that its started to chugger when at cruising speeds, when you reach say 30 mph and release your foot from the accelerator it starts to jump all over like kangaroo juice, it seems to run okay when cold but as soon as its warmed up then the problem starts, ive tried changing the lambada sensor, the spark plugs, the air flow sensor, the egr valve...i got it plugged into my mates laptop and it came up with both the egr valve and lambada sensor as being the faults but as i said they have been changed and its still the same,it also uses alot of petrol,i done 300 motorway miles and i used £50 in fuel........i would really appreciate some help on this as its now doing my head in....thanks for taking the time to read this
    9obamartins

  2. #2
    Status
    Offline
    gsi_10's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    4,812
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    £50 for 300 miles, i may stand corrected but i think that aint too bad for the recent fuel prices. I did around 70 motorway miles a day in my wee 1.3 and i was around £8 odds so to me the consumption aint too bad

  3. #3
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    What brand of EGR did you fit? Plenty of the cheaper brands are useless, Delphi is the one to go for.

  4. #4
    Status
    Offline
    9obamartins's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Thumbs Up

    Quote Originally Posted by gsi_10 View Post
    £50 for 300 miles, i may stand corrected but i think that aint too bad for the recent fuel prices. I did around 70 motorway miles a day in my wee 1.3 and i was around £8 odds so to me the consumption aint too bad
    thanks for your reply, i thought it was abit steep coz it is holding back and i thought it was using loads of petrol as the fuel gauge seems to go down abit too fast

  5. #5
    Status
    Offline
    9obamartins's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by nry View Post
    What brand of EGR did you fit? Plenty of the cheaper brands are useless, Delphi is the one to go for.
    it was a Delphi one, but it was a second hand from a salvage yard, ive also changed the coil pack but went back to my original one as i thought it seemed to run abit better than the replacement one

  6. #6
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Get a new Delphi EGR...

  7. #7
    Status
    Offline
    9obamartins's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question sorted !!!!!!

    Quote Originally Posted by nry View Post
    Get a new Delphi EGR...
    ive just unplugged the EGR valve and it seems to be running okay now, by doing this can it do any harm?

Similar Threads

  1. Do you have a 'natural cruising speed'?
    By dannymccann in forum Astra Discussion & Chat
    Replies: 39
    Last Post: 16-01-2009, 00:05
  2. Your Best Ever Cruising Tracks!
    By A51M in forum Chit Chat and a Warm Welcome!
    Replies: 24
    Last Post: 08-10-2007, 19:31
  3. JimmyC cruising!
    By toyboy in forum Spotted and Flyered
    Replies: 1
    Last Post: 02-06-2007, 15:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •