Results 1 to 10 of 10

Thread: Massive flat spot - Opinions needed

  
  1. #1
    Status
    Offline
    Yeti's Avatar
    AOC Newbie
    Join Date
    Oct 2007
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Massive flat spot - Opinions needed

    Hi

    I've got a problem with my Astra H 2.0T (170) Z20LEL where it will not rev any higher than 4,200rpm.

    I'm calling it a flat spot but it's not really. As soon as it gets to about the 4k mark it feels like the rev limiter has cut in.

    The point at which it does it varies a bit, some days its 4,200 others it will go to 5,000.

    There's no warning or service lights showing and no errors logged when I connect using OBDII software.

    I've got a sneaking suspicion that it could be the MAF but last time I checked with Vauxhall they were £260 + VAT a piece so just wanted a second opinion before I shell out.

    Thanks for looking

  2. #2
    Status
    Offline
    PLAGUE91's Avatar
    AOC Obsessed
    Join Date
    Apr 2010
    Posts
    1,146
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had a similar problem with my clio.
    what happened there is the cat was falling apart and bits were being lodged in the pipe. sometimes they'd sit flat and not be much of a problem, other times they'd clog the pipe and it wouldnt rev over about 2200.

  3. #3
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Could be a dicky rpm sensor?

  4. #4
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    No need for two threads - have moved this one to the diesel section where it should get a better response

  5. #5
    Status
    Offline
    AndyH's Avatar
    Bit busy... be back soon!
    Join Date
    Jul 1971
    Drives
    Astra Coupe 2.2
    Posts
    300,024,286
    Mentioned in
    133 Post(s)
    Quoted
    30 Post(s)
    Follow AndyH On Twitter Add AndyH on Facebook Add AndyH on Google+
    Z20LEL is turbo petrol mate
    Actively proving that post counts mean jack sh*t since 1971

  6. #6
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Lol, I'm not awake tonight, sorry! Saw the 4400 rpm and thought diesel!

  7. #7
    Status
    Offline
    Yeti's Avatar
    AOC Newbie
    Join Date
    Oct 2007
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by PLAGUE91 View Post
    i had a similar problem with my clio.
    what happened there is the cat was falling apart and bits were being lodged in the pipe. sometimes they'd sit flat and not be much of a problem, other times they'd clog the pipe and it wouldnt rev over about 2200.

    I've had this too a few years ago on a V6 Mondeo but there was a whisling noise where the bits were blocking the pipe, but can't hear anything now.

  8. #8
    Status
    Offline
    Yeti's Avatar
    AOC Newbie
    Join Date
    Oct 2007
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by AndyH View Post
    Z20LEL is turbo petrol mate
    Thanks, I didn't like to say anything!

  9. #9
    Status
    Offline
    bennn's Avatar
    AOC Newbie
    Join Date
    Mar 2010
    Posts
    13
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    my moneys on the CAT falling apart and blocking the exhaust mate,

  10. #10
    Status
    Offline
    PLAGUE91's Avatar
    AOC Obsessed
    Join Date
    Apr 2010
    Posts
    1,146
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Yeti View Post
    I've had this too a few years ago on a V6 Mondeo but there was a whisling noise where the bits were blocking the pipe, but can't hear anything now.
    haha same here! it sounded almost like my little clio had a turbo, although the fact that i was limping home at 25 mph spoilt the effect a bit

Similar Threads

  1. flat spot
    By kevpott in forum Turbo Petrol Engines inc. Transmissions
    Replies: 22
    Last Post: 18-04-2011, 22:33
  2. Flat Spot between 4K - 5K
    By cwaigy in forum Turbo Petrol Engines inc. Transmissions
    Replies: 4
    Last Post: 26-09-2007, 08:55
  3. 2.2 flat spot
    By greeny691 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 1
    Last Post: 23-09-2007, 10:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •