Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: These Pistons Ok To Use?

  
  1. #1
    Status
    Offline
    DarrenG's Avatar
    AOC Regular
    Join Date
    Jan 2006
    Posts
    200
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    These Pistons Ok To Use?

    Z20LET engine, cam belt slipped a few teeth... Got the head off and there is no major damage by the looks of things, going to get the head pressure tested tomorrow and see how many valves i need.



    All 4 pistons have this damage, the gouge is about 2/3mm deep on all. If I just sand the sharp edges down will the pistons be ok?

    Thanks

  2. #2
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    nope just replace them why the engine is in parts of they will blow up

  3. #3
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cant quite see.

    Any chance you could make the pictures bigger.
    The truth is always the truth even if you haven't realised it yet...

  4. #4
    Status
    Offline
    MatG's Avatar
    Club Chairman
    Join Date
    May 2003
    Posts
    34,568
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    **** Thread moved *****

    Please can you read this thread

    http://www.astraownersclub.com/vb/sh...d.php?t=249709
    Been apart of the inner circle since 2001
    Click Me to Join Astra Owners Club Full or Lite Members

  5. #5
    Status
    Offline
    BurrTony's Avatar
    AOC Obsessed
    Join Date
    Jul 2009
    Posts
    1,152
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Those pistons are fine to reuse just take the sharp edges off as you suggested. Sadly the valves wont be.

  6. #6
    Status
    Offline
    Dazal's Avatar
    South Wales RO
    Join Date
    May 2009
    Posts
    941
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Imo i would replace them.....as the valves smacking the pistons like that will weaken them.....
    Had 1st hand experiance of this in work,,,,,
    Valves hit pistons, marked them, costs to be kept down, reused old pistons, 5k l8r vehicle comes in with misfire, on strip down pistons are cracked across and down from where the valves hit them...

  7. #7
    Status
    Offline
    jamesmurray's Avatar
    AOC Fanatic
    Join Date
    Sep 2005
    Posts
    590
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    that all looks fine to me. the pistons have cutouts on the inlet sides anyway. the damage only looks minor. ive rebuilt engines after cambelt slips before with more damage and theres not been a problem.

    jimbo
    ASTRA MK4 GSI TURBO
    WAS CS3 268bhp & 282lb/ft
    NOW CS4 279bhp & 336lb/ft

  8. #8
    Status
    Offline
    DarrenG's Avatar
    AOC Regular
    Join Date
    Jan 2006
    Posts
    200
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)
    ok thanks, i'll just try and tidy these ones up then and then cross my fingers lol

  9. #9
    Status
    Offline
    nry's Avatar
    Cumbria RO | Club Team
    Join Date
    Mar 2008
    Posts
    25,986
    Mentioned in
    48 Post(s)
    Quoted
    1 Post(s)
    Hmm, I'd change them myself. You've probably got weakened pistons now even though they might 'look' OK to you. The valves could easily have mis-shaped the piston walls which and you may also get uneven temps on the piston faces now as they won't dissipate heat as they did before the damage.

    Given the work involved in replacing them now compared to the damage or hassle of replacing them again in the future, do it now imho.

  10. #10
    Status
    Offline
    D4nnyGsi's Avatar
    AOC Obsessed
    Join Date
    Jun 2007
    Posts
    1,031
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Id re-use them. Same as few posts above, i've built engines back up when the cambelt snapped before and never had a problem.

    Iv also built a zlet back up with worse marks than those, still running strong on stage 4 map

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •