Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Astra 1.7 DTI Y17DT missing and cutting out.

  
  1. #1
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra 1.7 DTI Y17DT missing and cutting out.

    A mate of mine has a 2002 astra 1.7 DTI with the Y17DT Isuzu engine. He came to mine today and asked me if i knew what was wrong with it as the engine is missing like mad when warm and also cutting out. I told him the common problem being the EDU and dry solder joints so he is swapping the EDU with another one from another car on monday to try. He's already swapped the MAF with a known good unit and that didn't work.

    Do you think the problem is with the EDU or could there be other causes?

    Can the EGR be cleaned on this engine? Is it hard? where is it?

    Also there was a thread all about re-soldering the EDU dry joints but i cant seem to find it. Can anyone point me in the right direction.

    cheers.

  2. #2
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds very much like the EDU.
    If you open the back up, use a screwdriver it comes off with a bit of force.
    Shine a light on all the solders and one will look dull rather than shine, that is the dry solder joint.

  3. #3
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers.. i'll tell my mate tomorrow.

    I've just found the post with the picture too. http://www.astraownersclub.com/vb/sh...=133082&page=2

    and picture,,

  4. #4
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any luck with the car?

  5. #5
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ive not seen or heard anything yet.

  6. #6
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ECU was resoldered and the problem is still present. Any suggestions?
    Astra H 1.7 CDTI Life (80hp ) with a few extras
    Incl, SMD dash conv, CC, Half Leather, 3-line display, CheckControl, ComfortClosure, Angel Lights, Front Fogs, Insignia Washer Jets + more

  7. #7
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    A resolder may or may not fix the problem. The only real test is to replace with a working one. Other things i am aware that should be checked are vacuum hoses, ECT and crank sensor (i believe).
    Are there any fault codes showing?
    Also as for egr valve you can unplug the vacuum hose and plug it to disconnect it.

  8. #8
    Status
    Offline
    paulthewafu's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If this helps, I've just resoldered 3 terminals within my EDU last night that were different to the one arrowed in the posted diagram. The ones that I did were the 3 round shaped terminals that form a triangle directly above those 4 red dots you can see at the bottom of the circuit board. All 3 joints were completely cracked, hence you could see a black ring around each terminal.

  9. #9
    Status
    Offline
    jiberson's Avatar
    AOC Obsessed
    Join Date
    Mar 2010
    Posts
    2,239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Wrong post

  10. #10
    Status
    Offline
    paulthewafu's Avatar
    AOC Newbie
    Join Date
    May 2010
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    What do you mean by wrong post?

Page 1 of 2 12 LastLast

Similar Threads

  1. Astra g '01 Y17DT rpm,fuel..etc..etc..etc..
    By Bokee in forum Diesel Engines inc. Transmissions
    Replies: 3
    Last Post: 14-02-2008, 09:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •