Results 1 to 7 of 7

Thread: Astra not revving over 4000rpm

  
  1. #1
    Status
    Offline
    raizan's Avatar
    AOC Newbie
    Join Date
    Dec 2008
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra not revving over 4000rpm

    Hi there guys my Astra Convertible MK4 1.8 starts fine but under revs and does not rev over 4000rpm was wondering what could be causing this?
    If i start the engine first thing in the morning then it runs fine but as soon as i shut it off even for a min it doesn't rev past 4000rpm on none of the gears or even when i put my foot on natural anyone know what this might be? thanks

  2. #2
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    it sounds as though it is in 'limp' mode, do the pedal test or code read it and see what fault codes appear.

  3. #3
    Status
    Offline
    raizan's Avatar
    AOC Newbie
    Join Date
    Dec 2008
    Posts
    21
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok will do Steve when i get home from work are there any common causes that put the car in 'limp' mode?

  4. #4
    Status
    Offline
    k.a.r.l's Avatar
    AOC Obsessed
    Join Date
    Jun 2008
    Posts
    1,986
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    poss cam sensor its normally that

  5. #5
    Status
    Offline
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,066
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    as above crank/cam sensor or an emmisions related issue, best get codes first and then it can be determined properly mate

  6. #6
    Status
    Offline
    dtm_chris's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    2,108
    Mentioned in
    3 Post(s)
    Quoted
    2 Post(s)
    cam sensor i reckon.
    Now drives : 2002 Astra SRi Turbo in Black
    PREVIOUS ASTRA'S : 1990 GTE 2.0 8v | 1993 1.4 GLS | 1994 1.6 Cesaro | 1995 1.8 16v Sport

  7. #7
    Status
    Offline
    Kier's Avatar
    AOC Regular
    Join Date
    Apr 2010
    Posts
    285
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had the same problem for a few weeks when I first bought my car (1.8 16v) and I had the cam sensor replaced like 3 times and then was told its my wiring so go for the cheapest first dude (cam sensor)

    Cost me last time around £30 for the part and £30 labour

Similar Threads

  1. HELP just got 1.8 astra bertone wont rev over 4000rpm
    By dpbertonecoupe in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 9
    Last Post: 08-08-2010, 20:39
  2. Excess revving/auto revving on cold engine start up
    By sxiscott in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 7
    Last Post: 10-02-2006, 00:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •