Results 1 to 5 of 5

Thread: Engine problem, please help

  
  1. #1
    Status
    Offline
    finny's Avatar
    AOC Fanatic
    Join Date
    May 2006
    Posts
    323
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Engine problem, please help

    Hi guys, got a little problem with my car and hoping someone on here can help pin point the problem.

    Its a 2002 Astra Coupe 2.2 Petrol

    Whats happening is that the car will start and drive fin, after about 5 mins if I come to a stop the car with struggle to idle and majority of the time it will stall. Also whilst going along the car will judder and pull like a valve or sensor is not right.

    For me to not let it stall when i come to traffic lights or anything im having to hold the accelerator at about 1500-2000 rpm.

    Any ideas people?
    MSN: cfindon@hotmail.com feel free to add me!!

    2002 Astra Coupe 2.2 Bertone
    in Breeze Blue
    ON THE LOOKOUT FOR SOME 18's!!!!!

  2. #2
    Status
    Offline
    JBee's Avatar
    AOC Fanatic
    Join Date
    Nov 2009
    Posts
    818
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Definately sounds like an EGR issue.

  3. #3
    Status
    Offline
    gregmilne2's Avatar
    AOC Newbie
    Join Date
    Mar 2009
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had the same, had it up to the garage countless amounts of times and read a post on the net about the throttle body gunking up. They cleaned it and it ran PERFECT. I couldn't believe such a small thing could make such a big difference

  4. #4
    Status
    Offline
    Blue_Sport's Avatar
    AOC Obsessed
    Join Date
    Aug 2009
    Posts
    1,358
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    take the throttle body off and give it a good clean, mine did this for a while, i changed the TB along with the drive belt, all gone now. the TB was in a bad way too. i have also had the egr cheat done. my car runs beautifully now.

  5. #5
    Status
    Offline
    finny's Avatar
    AOC Fanatic
    Join Date
    May 2006
    Posts
    323
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    well took it to my mechanical friend, and he cleaned the throttle body and egr valve and it seemed to clear. Took the car for a good run the other day and after about 20 mins, once the engine was warm it started again. Got it home and left it running and it sounded like it wasn't firing on all cylinders, and was kinda spluttering.
    MSN: cfindon@hotmail.com feel free to add me!!

    2002 Astra Coupe 2.2 Bertone
    in Breeze Blue
    ON THE LOOKOUT FOR SOME 18's!!!!!

Similar Threads

  1. Advice on engine problem.....or no problem?
    By jon0881 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 24-07-2014, 13:06
  2. 1.6i 8v engine problem
    By Mustang in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 11
    Last Post: 17-02-2009, 20:29
  3. Engine problem
    By flipcjl in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 08-03-2007, 17:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •