Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Complete list of Astra H / Zafira B diesel fault codes

  
  1. #11
    Status
    Offline
    MorrisMan'91's Avatar
    AstraSport Member
    Join Date
    Aug 2008
    Posts
    279
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any ideas what a P1811 'Torque signal malfunction' means?
    I keep getting the ESP light come on and stay on whilst driving without it having kicked in or being switched off.

    Also, any ideas what a P5007 is??

    * i think the P500 code is something to do with my slipping clutch *

    Thanks.

  2. #12
    Status
    Offline
    escapejoanne's Avatar
    AOC Newbie
    Join Date
    Nov 2011
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    04 vauxhall astra 1.7 tdi

    can anyone help me i have 04 vauxhall astra 1.7tdi, showing codes p0105[A] boost presure sensor circuit range/performance . also code p0400 [9] exhaust gas redirection flow excessive detected . thanks joanne

  3. #13
    Status
    Offline
    astrasteve's Avatar
    AOC Obsessed
    Join Date
    Jan 2009
    Location
    East Yorkshire
    Posts
    3,257
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    p0400 is your egr valve
    p0105 will be the map sensor top left on the back of the engine in the inlet manifold

  4. #14
    Status
    Offline
    wilko_sri_derv's Avatar
    AOC Newbie
    Join Date
    Jun 2012
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    error code 2075

    hi just been looking through the list of codes and can honestly say its a big help, i have a 07 1.9 cdti sri 150 astra and the other night whilst travelling at 80mph the ABS and TRACTION CONTROL light came on and and lost all power steering :/, once i turned the engine off it wouldnt start again so after getting it home and charging the battery i had all steering and no dash lights on so i carried out the pedal test which came up with the code 2075 which suggest swirl control sensor or something, ive carried out tests etc with the multi meter and the battery is only receiving between 10-12volts whilst running and its slowly decreases whilst on load, can anyone please advise me if this could be the sensor the code comes up with thats causing this or an alternator fault, the car has only done 28k so in my mind the alternator should have plenty of life in it! thanks for taking the time to read this and would appreciate any information thanks

  5. #15
    Status
    Offline
    HBPeter's Avatar
    AOC Newbie
    Join Date
    Nov 2008
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Eco4

    I have an 02 ECO4 Astra. Now and again the Engine Management Light comes on(mainly when the engine is working hard, climbing a long hill e.g.)
    The car switches to Limp Mode. IF I turn it off, wait a min, then start it again, all is well, light out, car runs ok.

    The last week the car isnt running quite right, has a small 'rough spot' around 1800rpm, and sometimes when you accelerate nothing happens for a second or two and engine sounds rough, then it clears and drives as normal.

    I have had the car for about 4years and its now got 129k miles in it. I havent tried the fault code thing yet, but when I do I post any codes that come up. I presume the pedal trick will work with this age model?

    Any ideas.

    Peter

  6. #16
    Status
    Offline
    lchambers91's Avatar
    AOC Newbie
    Join Date
    Sep 2012
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    tried the pedal test and comes up with nothing at all. How firm do you touch the accelerator?

  7. #17
    Status
    Online
    DiscoFred's Avatar
    Hulk smash!!
    Join Date
    Sep 2008
    Posts
    13,153
    Mentioned in
    21 Post(s)
    Quoted
    5 Post(s)
    I moved your post into a new thread here for you...

    http://www.astraownersclub.com/vb/sh...d.php?t=369625

    It's clobberin' time!


  8. #18
    Status
    Offline
    geoffre's Avatar
    AOC Newbie
    Join Date
    Sep 2012
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Great,test worked.P0380 tells me i have a glow device problem. Is it the relay or glow plug probs.I have experienced bad starting on occassions.

  9. #19
    Status
    Offline
    poppette's Avatar
    AOC Newbie
    Join Date
    Feb 2012
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Im getting a P0500 code as well it seemed to happen after I dropped a gear to overtake, the engine managment light came on and then went off again all seems O.K. now. Did go into limp mode but was O.K. after switching off and then back on again.

    poppette

  10. #20
    Status
    Offline
    sc8tt's Avatar
    AOC Newbie
    Join Date
    Aug 2010
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    error codes not on list

    My 2006 1.9 CDTI 120 comes up with error codes that are not on the list could anybody help out, they are:

    ECN 210870

    ECN 21397F
    ECN 213970

    Thanks

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. EML Fault Codes (Complete List)
    By chr15g in forum Turbo Petrol Engines inc. Transmissions
    Replies: 13
    Last Post: 08-01-2013, 22:47
  2. diesel '53 Astra fault codes
    By mantona in forum Diesel Engines inc. Transmissions
    Replies: 7
    Last Post: 18-04-2011, 22:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •