Results 1 to 7 of 7

Thread: Astra CDTI

  
  1. #1
    Status
    Offline
    dennis55's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra CDTI

    Hi, Im new to the forum and encountering my first fault with my Astra which I have owned since new. It`s an Astra Life 1.7 CDTi and every now and then, the engine maintenance light comes on and the accelorator pedal will not rev the engine. This happens more often than it did last week. The engine is still running but no power from accelorator pedal. Anyone any idea`s as to how this can be sorted without astronomical costs.
    Kind regards Dennis swift

  2. #2
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have you had the fault codes read? Try doing the pedal test

    Foot on the brake and the accellerator pedal
    Key into the ignition and turn to position 2 (dash lights up but do not start the engine)
    any stored error codes will be displayed as ECN Numbers in the tacho display.

    Jot them down if there are any there and then post back.

  3. #3
    Status
    Offline
    dennis55's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ok, I did as told and the dash light stated insp ecn 112252.

    Regards Dennis swift

  4. #4
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    This code relates to the following. From what you have already described above it seems like the accelerator pedal sensor has gone.

    P1122 Accelerator Pedal Position Sensor 2 High Input C-009
    P1122 Accelerator Pedal Position Sensor 2 Range/Performance C-009
    P1122 Accelerator Pedal Position Sensor 1 and 2 Signal Incorrect Ratio C-009

  5. #5
    Status
    Offline
    dennis55's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks very much for the quick reply and help. As a none mechanic and certainly no auto electrician, what is the likely outcome from this, will it cost a fortune or is it something I could sort myself.
    Kind regards Dennis swift

  6. #6
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Found this on Ebay. I'm not sure if its the same on all Astra H's. The part number of this one is 93178259. Hopefully someone will come along soon and can clarify if its the right part.

    http://cgi.ebay.co.uk/Vauxhall-Astra...item4cebe03962

    It doesn't look too hard to change either. (don't quote me on that though...)

  7. #7
    Status
    Offline
    dennis55's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Took the car on Friday to have it checked over, the warning code indicated the accelorator pedal was the fault. They asked me to leave it until today when it would be ready. Got a phone call at dinner time to go and collect the car. As I drove it away the same fault occurred again, maintenance warning light and no power to the pedal. I returned it but no reply as yet, the garage is now closed until tomorrow.

Similar Threads

  1. Astra H - 1.7 cdti, 1.9 cdti OR 1.6 petrol? HELP
    By uzyg in forum Astra Discussion & Chat
    Replies: 2
    Last Post: 16-07-2012, 13:13
  2. Does the Vectra C 1.9 CDTi share the same box as the Astra H 1.9 CDTi
    By Stevie C in forum Car Chat (other marques/models)
    Replies: 10
    Last Post: 02-04-2012, 08:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •