Results 1 to 7 of 7

Thread: Lack of power & black smoke

  
  1. #1
    Status
    Offline
    Sally_N's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Lack of power & black smoke

    Hi everyone I'm having a problem with my 06 Astra cdti diesel, 40 K miles, it's lost power and is black smoking , A local garage has told me i need new inlet manifold and has told me it will cost around £800 !!!!!! which is very expensive for a car that has only done that mileage, they also told me this is a common fault with Vauxhall, are they ripping me off ? any help appreciated

    Thanks, regards Sally ann

  2. #2
    Status
    Offline
    AndyH's Avatar
    Bit busy... be back soon!
    Join Date
    Jul 1971
    Drives
    Astra Coupe 2.2
    Posts
    300,024,286
    Mentioned in
    133 Post(s)
    Quoted
    30 Post(s)
    Follow AndyH On Twitter Add AndyH on Facebook Add AndyH on Google+
    Is it a 1.9 150?

    It sounds like it may be the swirl flaps in the inlet manifold, which is a well known problem. They can get caked up with soot and seize up, causing the symptoms you describe. All the cases I've read of it require a new manifold I'm afraid, and that price is about in the ball park... it's on the back of the engine, so is rather difficult to get to access-wise.

    And welcome to the club
    Actively proving that post counts mean jack sh*t since 1971

  3. #3
    Status
    Offline
    alan_tre's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    626
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if theres no power below the turbo and black smoke thats the egr.... i had this cleaned it and the problem was gone

    worth a clean costs nowt.... when ever any 1 syas those problems its mainly the egr
    astra cdti 202bhp 323 lb-ft torque 45mpg
    audi tt 180bhp and no lb-ft torque lol

  4. #4
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If its the 1.9 150 then clean your EGR first.... Follow the guides on the forum. As said above, it costs nowt bar a can of carb cleaner. Also check your swirl flap connector rod hasn't fallen off.

  5. #5
    Status
    Offline
    Sally_N's Avatar
    AOC Newbie
    Join Date
    Apr 2010
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for help everyone, I got my dad to have a look Monday, he stripped the egr and cleaned it all up and said the swirl flaps are moving ok when the engine is revved, but there's a fault code saying P 1125 Accelerator pedal position ( APP) System, anyway he cleared the code and it hasn't came back up to now, it seems to be running better but still smoking a bit on accelaration

  6. #6
    Status
    Offline
    alan_tre's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    626
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    it will always smoke a bit when giving it some beans.. But it shouldnt be smoking when ya just sittinf say em 30mph in 3rd gear. mine does when im flat to the floor and going past 4krevs lol...

    Is it driving better?
    astra cdti 202bhp 323 lb-ft torque 45mpg
    audi tt 180bhp and no lb-ft torque lol

  7. #7
    Status
    Offline
    ljones60's Avatar
    AOC Regular
    Join Date
    Sep 2009
    Posts
    270
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when your dad cleaned the EGR did he remove the solenoid and clean that as well, because if he didn't then it problem will more than likely come back sooner rather than later.

    This is the process for cleaning it completely.

    When you have the EGR off the car you’ll have the following



    Then undo the torx screws



    You’ll then see the following



    Drill a hole in the top of the plastic shroud holding in the solenoid as follows, 3mm should be enough



    Using a punch or similar hit directly the centre



    You can then take out the solenoid

    Don’t lose the spring !

    You’ll end up with this



    Put together like this



    Clean all of the corrosion off



    At this point I greased the inside where there are moving parts, place back in





    And hit back in with a hammer



    Ending with this




    Spray some grease through the hole at the top and your done.



    Complete !

Similar Threads

  1. black smoke and lack of power HELP !!
    By sqwiub in forum Diesel Engines inc. Transmissions
    Replies: 2
    Last Post: 12-04-2012, 22:07
  2. 1.3cdti black smoke, lack of power, is this my egr or turbo?
    By johnnystone in forum Diesel Engines inc. Transmissions
    Replies: 12
    Last Post: 17-01-2012, 15:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •