Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Help! - AFM Gone? Fault Codes

  
  1. #1
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Help! - AFM Gone? Fault Codes

    I believe my AFM has now had it - Got these fault codes from paper clip test which leads me to believe it has, but if someone could confirm before i buy one, that would be awesome (iv tried disconnecting the battery and leaving overnight too with no joy):

    0100 - Mass or Volume Air flow Circuit Malfunction
    0110 - Intake Air Temperature Circuit Malfunction
    0505 - Idle Control System Malfunction


    Thanks all!

    Rob

  2. #2
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any advice?

  3. #3
    Status
    Online
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,069
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    looks like the correct set of codes for an AFM failure and similar to the ones i had on my Z18XE a while back

  4. #4
    Status
    Offline
    andrewdevlin86's Avatar
    AOC Lite Member
    Join Date
    Oct 2008
    Posts
    959
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have these first two codes but haven't got around to sorting yet. If you do it first let me know how you get on and I'll do the same. Watch this space
    2000 1.8 CDX money guzzler a.k.a Bessie

  5. #5
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Will do. im gona get a new AFM today, so will let you know the outcome

  6. #6
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any last thoughts or suggestions before i go an buy a new AFM?

    Thanks all!

  7. #7
    Status
    Online
    stevej66's Avatar
    Tech Advisor/Moderator
    Join Date
    Jun 2009
    Location
    on the sofa
    Posts
    7,069
    Mentioned in
    52 Post(s)
    Quoted
    240 Post(s)
    just before you go and change the AFM, check over the throttle body and make sure that it is clean with no leaks as i am at odds with the P0505 code

  8. #8
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by steve1412 View Post
    just before you go and change the AFM, check over the throttle body and make sure that it is clean with no leaks as i am at odds with the P0505 code
    Thanks Steve - I clean the throttle body on a regular basis. all seals checked and definately no leaks.

    Iv ordered the AFM, but were out of stock. Gona be picking it up tomorrow

  9. #9
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Im now at a loss.................

    Replaced the AFM with a genuine part last night and disconnected the battery. Reconnected this morning and still same problem and same fault codes.

    Even tried a friends AFM and still same thing - Surely it cant be 3 AFM's at fault??!!

    Can anyone offer any suggestions?

    Cheers,
    Rob

  10. #10
    Status
    Offline
    essex_rob's Avatar
    AOC Fanatic
    Join Date
    Aug 2008
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Done abit of searching, and think it may the Idle Control Valve that is playing up. Looked at ther How To's, and theres abit of a problem, my ICV is attached to my throttle body and theres no way to remove it. The How To shows that you can on the model they use which is an early version.

    I know this as iv taken the whole throttle body off before to clean it and noticed that it couldnt be removed.

    Any thoughts?

Page 1 of 3 123 LastLast

Similar Threads

  1. Temp gauge fault, 2 Fault codes
    By Autosparks in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 29-11-2008, 17:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •